はじめに

「アタッシェケース」は日常的に使うことを想定し、見た目のシンプルさと簡便な操作性に注力しながらも、世界標準の暗号アルゴリズムを採用した強力なファイル暗号化ソフトです。

ファイルをドラッグ＆ドロップするだけで、簡単に暗号化することができ、フォルダごとドラッグ＆ドロップした場合には、１つにまとめて暗号化ファイルを作ります（フォルダごとパックします）。

なお、暗号化の際にはデータに圧縮がかかりますので、サイズがコンパクトになります。

復号化する（元に戻す）際にもドラッグ＆ドロップするか、ダブルクリックしてパスワードを入力するだけで、簡単に元のファイルやフォルダに戻すことができます。

また、実行形式（*.exe）ファイルとして出力できますので、アタッシェケースを持たない人へ暗号化ファイルを渡すことができ、復号することができます。

暗号化アルゴリズムには、2000年10月に（NIST: http://csrc.nist.gov/）によって、次世代暗号化標準 AES（Advanced Encryption Standard）として選定された“Rijndael（ラインダール）”を採用し組み込んでいます。AESではブロック長が128ビット固定となっていますが、アタッシェケースではRijndaelの仕様を採用し、鍵、ブロック長ともに256ビットになっています。

なお、乱数による初期化ベクトル（IV）を生成してからCBCモードで暗号化し、第三者による解析も防ぐよう工夫されています。（→詳しくは、「暗号化アルゴリズムについて」のページを参照ください。）

**************************************************
  注意！！　以前のバージョンをお使いの皆様へ
**************************************************

アタッシェケースver.2 から、新しい暗号アルゴリズムを採用したことで、生成する暗号化ファイルのデータ構造を一新しました。そのため、ver.2 以降で作成した暗号化ファイルを、ver.1.** のアタッシェケースで復号することができなくなります。

複数間でのファイルのやりとりを行う場合は、すべてのアタッシェケースをver.2 以降にアップデートしてください。なお、前バージョンで作成された暗号化ファイルは、最新版（ver.2以降）でも問題なく戻すことができます。一応データファイルは上位互換になっています。

《暗号化ファイル》

ver.1.** → ver.2以降 ○ 復号O.K.

ver.1.** ← ver.2以降 × 復号N.G.

  • 『アタッシェケース』は、フリーソフトウェア として配布しています。各自の責任においてご自由にお使い下さい。（→詳しくは「使用条件・免責」のページを参照ください。）
  • なお、配布するすべてのファイルは、最新のウィルス定義ファイルを載せたNorton AntiVirusで、ウィルスチェック済みです。

インストールされるファイルリスト

アーカイブに同梱され、お使いのPCへインストールされるファイルは以下の通りです。

ATCHCASE | .EXE | ：実行ファイル。本体です。
ATCSETUP | .EXE | ：本体から呼び出され、関連付けを行う実行ファイルです。
ATCHCASE | .CHM | ：ヘルプファイル（この見ているファイルです）
README | .TXT | ：概要を記した最初にお読みいただきたい説明書です。

Copyright© 2002-2009 M.Hibara, All rights reserved.


動作環境

基本的に、Windows98/NT/2000/XP/Vista でご使用いただけます。
ただし、日本語版以外の上記OSを使った場合、正常に動作しないことがあります。
日本語版以外で使用される場合は、英語版をお使いください。

一応、Windows Vistaにも対応していますが、当方に確認環境がなく、完全な確認はできていません。
ただ、一部タスク切り替えでウィンドウ画面表示できないなどあるかもしれませんが、基本的にXPで動くアプリケーションはVistaでも動作することが保証されていますので、問題なく動くとは思います。

Windows 95/Meでも動作するとは思いますが、この環境も作者にはなく、動作確認を行っておりません。
なので、こちらは申し訳ありませんが、サポート外とさせてください。

  • ユーザーの方からWindows Me でも動作するという報告をいただきました。バグもいくつか修正しましたし、たぶん大丈夫かと（^^;
  • Windows95で動作させると、一部関連付け設定がきかない、ネットワーク上のファイルを暗号化できないなどの問題があるようです。

なお、「comctl32.dll」のバージョンが古い（version4.72以降ではない）と、動作しないことがあります。起動しない場合は、以下のディレクトリを見て、ファイルのバージョンを確認してください。おそらく、あなたのPCに「Internet Explorer4.0」以降か、「Office97」以降がインストールされていれば、大丈夫かと。

Win98系 C:\\Windows\system

WinNT系 C:\WINNT\system
※OSのインストール先がのドライブが「C」だと想定した場合。

  • なお、開発はWindowsXPで行っているため、どうしてもそれ以外の環境（特にWin98/Vista）のチェックが甘めになっています。不具合等が見つかった場合は、ご一報いただければ幸いです（→「連絡先（サポート）」）。
  • 特にVista上での動作など、詳細なレポートをいただけるとうれしいです。


インストール/アンインストール

インストール

  • atcs265.exe（インストーラ）からインストールする場合

    そのまま「atcs265.exe」をダブルクリックして、セットアップウィザードの指示に従ってインストールしてください。ほとんどユーザーによって設定することはないと思います。

  • atcs265.lzh（圧縮されたファイル）からインストールする場合

    前に使用されていたフォルダへすべてのファイルを上書きしてください。フォルダが変わると、拡張子の関連付け設定などが無効になってしまいます。フォルダを変更したい場合は、次項の方法で、いったん古いアタッシェケースを削除してからインストールし直してください。

アンインストール

  • atcs265.exe（インストーラ）からインストールした場合

    「コントロールパネル」の「アプリケーションの追加と削除」から（WindowsXPなどは「プログラムの追加と削除」から）、『アタッシェケース』を選択して、削除してください。ただし、拡張子（*.atc）との関連付け設定を解除したい場合は、以下の項目を参照してから行ってください。

  • atcs265.lzh（圧縮されたファイル）からインストールした場合<

    アタッシェケースがあるフォルダごと削除してください。
    ただし、拡張子（*.atc）との関連付け設定を解除したい場合は、以下の項目を参照してから行ってください。

  • 関連付け設定を解除するには

    *.atcファイルへの関連付け設定を解除したい場合は、上記の削除を行う前に、AtchCase.exe を起動して、「設定(T)」→「動作設定(O)」から「システム」タブを選び、「暗号化ファイル（*.atc）の関連付け設定」ボタンを押してください。システムから関連付け設定が削除されます。
    • Windows Vistaの場合は、設定の際に管理者権限を求められます。

    アンインストーラや、上記の方法を行えば、レジストリ情報は削除されます。もしも何らかの理由で手動削除を行いたい場合は、以下のレジストリを削除してください。

    HKEY_CURRENT_USER\Software\Hibara\AttacheCase

    【注意！】
    • 手動でレジストリ操作を行う場合は、十分な知識と注意が必要です。自信のある方のみ行ってください。誤ったレジストリ操作によってシステムに何らかの障害が起こっても、当方では責任は負いかねます。
    • レジストリがそのまま残っていたとしても、今後の動作に何の支障もありません。自信のない方はやめておきましょう（^^;）。


制限

アタッシェケースで作成できるファイルサイズには制限があります。
とはいっても、ほとんどがWindowsによるOSの制限です。

まず、あなたがお使いのパソコンのファイルシステムによって、ハードディスク上に作れるファイルサイズが決まります。

FAT16 | Windows95 …ハードディスク自体が最大2GBに制限
FAT32 | Windows95 OSR2以降 …１ファイル4GBまでのサイズ制限
NTFS | WinodwsNT/2000/XP …１ファイル2TB(2000GB）までのサイズに対応

もし巨大ファイルを扱いたい場合は、Windows2000/XPなどのOSにし、ファイルシステムをNTFSにしないといけません（※Win2000/XPでもFAT32のままのことがあります）。変換の方法は、ネットなどでお調べください。

この制限以上のファイルをアタッシェケースで暗号化ファイルを作成しようとすると、エラーが出て止まるようになっています。また、あまりないとは思いますが、NTFS上で暗号化した後（圧縮がかかります）、FAT32上のハードディスクで4GB以上になるように復号化（解凍・サイズ増加）すると、上記の理由でエラーになることもあります（^^;

さらに、アタッシェケースから正常に出力できる実行形式ファイル（*.exe）のサイズは、4GBまでと制限を受けます。これはメモリを4GB以上搭載できないというWinodwsの仕様からくるもので、4GB以上はWin32アプリケーションとして認識することができません（想定されていません）。

アタッシェケースでは一応4GB以上の実行形式ファイルを作ることはできますが、Windowsの方が認識できませんので注意が必要です。ただ、作成してしまっても、実行形式ファイル（*.exe）をそのままアタッシェケースへ投げ込めば、復号して戻すことができますので、大切なファイルが失われることはありません。


ファイルを暗号化する

使い方はいたって簡単です。アイコン、または開いたウィンドウ上に、暗号化したいファイルをドラッグ＆ドロップするだけです。

暗号化される前に、パスワード入力を求められますので、設定してください。

  • なお、パスワードの入力文字数には制限があり、大文字小文字を区別し、半角で32文字（全角だと16文字）以内です。

また、フォルダごと、アタッシェケースへドラッグ＆ドロップすることで、１つに圧縮＆パックして暗号化ファイルを作ることもできます。


ファイルを復号する（戻す）

これも暗号化と同じく、アイコン、または開いたフォーム上に、暗号化したファイルをドラッグ＆ドロップするだけです。

暗号化と同じく、パスワードを求められますので、自分で設定したパスワードを入力して復号化してください。

アタッシェケースファイル（*.atc）が関連付けされていれば、暗号化ファイルを直接ダブルクリックするだけで復号化処理を行います。
さらに、パスワードを記憶させ、処理後アタッシェケースを終了するよう設定されていれば（→「基本設定」）、ウィンドウが開いたままになることなくファイルが復号化され、暗号/復号化をあまり意識することなく便利に使えます。


自己実行形式への出力

暗号化の際に、以下の「実行形式出力」のボックスにチェックを入れ、暗号化を行うと、実行形式（*.exe）で出力することができます。
なお、F12キーを押すことでも、チェックボックスをON/OFFすることができます。また、
Ctrl + Enterキーでも実行形式出力で暗号化を行うことができます。

↓実行ファイル（*.exe）で出力されます。

アイコンも通常の暗号化ファイル（*.atc）とは異なるので、すぐにわかると思います。このファイルは、「アタッシェケース」がインストールされていないパソコンでも復号する（戻す）ことができます。アタッシェケースを持っていない方へ大切なファイルを渡すなどするときに便利な機能でしょう。ただし、いわずもがなですが、復号する際にはパスワードが必要です（^^;　相手が知っているか、伝えておく必要があります。

EXEファイルを実行することで、暗号化されたファイル/フォルダが復号化されます（戻ります）。

自己実行形式出力での注意点

自己実行形式出力の際に、注意する点がいくつかあります。

  • ファイルサイズが増加します。
    実行形式出力することで、通常の暗号化ファイル（*.atc）よりもファイルサイズが大きくなります。環境によって異なりますが、約220KBほど増加します。
    デカイよー、もうちょっと小さくできないの？というご意見もあると思いますが、作者のプログラミング能力の限界です（^^;）。今後の研究・リファインにご期待ください（笑）。

  • アタッシェケースで設定した内容は保存されません。
    実行可能形式で出力した際には、あなたがアタッシェケースで設定した内容は保存されません。つまり基本設定や、保存設定、削除設定、システムなどは、ファイルに含まれませんので注意が必要です。復号＆解凍するだけのシンプルな機能となります。

    たとえば、パスワードは必ず聞かれ、保存される復号されたファイルはEXEファイルのある場所で、元ファイル（*.exe）は削除されない、ということになります。

  • 出力した実行形式ファイルの配布条件などは特にありません。
    実行形式ファイルの配布は、自由に行ってかまいません。アタッシェケースが出力するファイルについては、通常の*.atcファイルも含め、自由に行うことができます。（→詳しくは「FAQ」および「転載・再配布」を参照ください。）


使用上の注意

パスワードを忘れた場合は、元に戻すことは不可能です。けっして作者宛にパスワードが分からない暗号化ファイルを、送りつけたりしないでください（^^;）。そもそも暗号化ファイルの中身が簡単に見えてしまうようでは意味がありませんし。

暗号化の仕組みは、パスワード自体をキーにして暗号化のシャッフルを行っているため（開く鍵としてではなく、暗号計算の材料として使っています）、暗号化ファイルにはパスワードが含まれていません。ひとたび、あなたがパスワードを忘れれば誰もファイルを戻すことはできません。ヘルプ冒頭にもありましたとおり、暗号化の手法自体はかなり強力です（笑）。パスワード管理には十分注意しましょう。

また、ファイル自体がネットワークを通して送受信したときや、メディアなど（FD,MOなど）へのファイル書き込みの際、ファイルの一部分が壊れた場合も、元には戻せません。これは当たり前のことですけども。


起動時のコマンドオプション

「起動時のコマンドオプション」が何のことか分からないユーザーさんには、まったく関係ありません。読み飛ばしてください（^^;

このページでは、アタッシェケースをより高度に使いこなしたい人向けに、カスタマイズの方法を説明しています。

アタッシェケースでは、起動時に引数を渡すことで、暗号/復号化処理を行うことが可能です。他のアプリケーションから扱ったり、バッチファイルなどから操作できます。たとえば、アタッシェケースのショートカットを作成し、「リンク先」に書き込むことでパスワードを使い分けて暗号/復号するなんて使い方も便利かもしれません。

ただ、この使い方は、パスワード文字列は隠されることなくそのまま記録、表示されることになるので、設定は十分注意して行ってください。あくまでこれも自己責任でお願いします。

【注意点】
  • 特に引数を指定しない場合は、すでに設定されている内容でアタッシェケースは起動します。たとえば「フォルダの場合、復号後に開く」の設定にふだんはONにしていると、引数でOFFと特に指定しないかぎり、復号後にフォルダを開く動作となります。
  • 引数の大文字小文字は区別しません。ただし、パスワードなど設定の中身は区別します。
  • 引数と"="（イーコール）の間に空白やTabなどの制御文字を入れると正しく認識できません。
  • 設定内容のパスワードに空白を入れたり、ファイルパスに空白が含まれる場合は、""（ダブルコーテーション）で引数全体を括ると正しく認識できます。
  • コマンドライン引数を指定して実行した場合は、終了時にその設定を保存しません。ユーザーキャンセルなどで処理を中止した際に、改めて動作設定を行っても反映されません。
  • アタッシェケースが出力した実行形式（*.exe）ファイルの暗号化ファイルに対して、コマンドラインでの指定はできません。できるのは本体（AtchCase.exe）へのみです。
  • コマンドラインオプションでアタッシェケースのすべての設定項目を指定できません（一部設定できないものもあります）。設定できる項目は以下の通りです。

基本設定

/p=[PASSWORD]
パスワード
ex). /p=hirakegoma ※パスに空白を含む場合は、ex). "/p=hirake goma"

/mempexe=[0,1]
記憶パスワードで確認なく実行する
ex). /mempexe=1 ※実行せず確認を行いたい場合は、ex). /mempexe=0

/opd=[0,1]
フォルダの場合、復号後に開く
ex). /opd=1 ※フォルダを開きたくない場合は、ex). /opd=0

/opf=[0,1]
復号したファイルを関連付けられたソフトで開く
ex). /opf=1 ※フォルダを開きたくない場合は、ex). /opf=0

/exit=[0,1]
処理後、アタッシェケースを終了する
ex). /exit=1 ※終了したくない場合は、ex). /exit=0

/front=[0,1]
デスクトップで最前面にウィンドウを表示する
ex). /front=1 ※前面にしたくない場合は、ex). /front=0

/nohide=[0,1]
「*」で隠さずパスワードを確認しながら入力する
ex). /nohide=1 ※隠して入力したい場合は、ex). /nohide=0

/exeout=[0,1]
常に自己実行形式で出力する
ex). /exeout=1 ※実行形式で出力したくない場合は、ex). /exeout=0

/chkexeout=[0,1]
メインフォームにそのチェックボックスを表示する
ex). /chkexeout=1 ※チェックボックスを表示したくない場合は、ex). /chkexeout=0

/askende=[0,1]
暗号/復号処理かを問い合わせる
ex). /askende=1 ※問い合わせをしたくないときは、ex). /askende=0

/en=1
明示的に暗号化を指定する
※このオプションを指定すると起動時に「暗号化」処理に移行します。

問い合わせオプションが指定されていても無視されます。

/de=1
明示的に復号化を指定する
※このオプションを指定すると起動時に「復号化」処理に移行します。

問い合わせオプションが指定されていても無視されます。

/nomulti=[0,1]
複数起動しない
ex). /nomulti=1 ※複数起動するときは、ex). /nomulti=0
保存設定

/saveto=[PATH]
常に同じ場所へ暗号化ファイルを保存する
ex). /saveto=MyData
※パスに空白が含まれる場合は、
"/saveto=C:\Documents and Settings\User1\My Documents"

/dsaveto=[PATH]
常に同じ場所へファイルを復号化する
ex). /dsaveto=MyData
※パスに空白が含まれる場合は、
"/saveto=C:\Documents and Settings\User1\My Documents"

/ow=[0,1]
同名ファイルの場合、確認無しに上書きする
ex). /ow=1 ※上書きを確認する場合は、ex). /ow=0

/orgdt=[0,1]
暗号化ファイルのタイムスタンプを元ファイルに合わせる
ex). /orgdt=1 ※タイムスタンプを生成時のままにしておくのは、ex). /orgdt=0

/now=[0,1]
復号したファイルのタイムスタンプを生成日時にする
ex). /now=1 ※元のタイムスタンプのままは、ex). /now=0

/allpack=[0,1]
複数ファイルは一つの暗号化ファイルにまとめる
ex). /allpack=1 ※まとめない場合は、ex). /allpack=0

/oneby=[0,1]
フォルダ内のファイルは個別に暗号化/復号する
ex). /oneby=1 ※個別に処理しない場合は、ex). /oneby=0

/nopfldr=[0,1]
復号するときに親フォルダを生成しない
ex). /nopfldr=1 ※復号するときに親フォルダを生成する場合は、ex). /oneby=0

/withext=[0,1]
暗号化ファイル名に拡張子を含める
ex). /withext=1 ※含めない場合は、ex). /withext=0

/autoname=[FORMAT]
自動で暗号化ファイル名を付加する
ex). /autoname=<filename>_<date:yymmdd><ext>

※autonameが指定されないと、この機能はOFFとなります。

※パスに空白が含まれる場合は、

ex). "/autoname=<filename>_<date:yymmdd><ext>"
削除設定

/del=[0,1,2,3]
暗号化した後、元ファイルを削除する
0: 削除しない
1: 通常削除
2: 完全削除
3: ごみ箱への削除
ex). /del=1 ※元ファイル削除しない場合は、ex). /del=0

/delenc=[0,1,2,3]
復号化した後、暗号化ファイルを削除する
0: 削除しない
1: 通常削除
2: 完全削除
3: ごみ箱への削除
ex). /delenc=1 ※元ファイル削除しない場合は、ex). /delenc=0

/chkdel=[0,1]
メインフォームにそのチェックボックスを表示する
ex). /chkdel=1 ※チェックボックスを表示したくない場合は、ex). /chkdel=0

/delrand=[0-99]
乱数を何回書き込み消去するか
0-99: 書き込み回数を指定します。
ex). /delrand=3 ※乱数書き込みしない場合は、ex). /delrand=0

/delnull=[0-99]
NULLを何回書き込み消去するか
0-99: 書き込み回数を指定します。
ex). /delnull=3 ※乱数書き込みしない場合は、ex). /delnull=0
動作設定

/comprate=[0-9]
圧縮設定（圧縮率）
0-9: 圧縮率を指定します。
ex). /comprate=6 ※圧縮しない場合は、ex). /comprate=0

/cmp=[0,1]
暗号化した後にデータのコンペアを行う
ex). /cmp=1 ※コンペアしない場合は、ex). /cmp=0
高度設定

/pf=[0,1]
パスワードにファイルの指定を許可する
ex). /pf=1 ※許可しない場合は、ex). /pf=0

/pfile=[PATH]
暗号時のパスワードファイルパス
ex). /pfile=C:\Temp\pass.txt
※パスに空白が含まれる場合は、
"/pfile=C:\Documents and Settings\User1\My Documents\pass.txt"

/dpfile=[PATH]
復号時のパスワードファイルパス
ex). /dpfile=C:\Temp\pass.txt
※パスに空白が含まれる場合は、
"/dpfile=C:\Documents and Settings\User1\My Documents\pass.txt"

/nomsgp=[0,1]
パスワードファイルがない場合エラーを出さない
ex). /nomsgp=1 ※エラーを出す場合は、ex). /nomsgp=0

/camoext=[EXT]
暗号化ファイルの拡張子を偽装する
ex). /camoext=.jpg ※偽装しない場合は、ex). /camoext=null
その他（コマンドラインからのみ）

/4gbok=[0,1]
実行形式のときに出力ファイルが4GBを超えても警告メッセージを出さない
※実行形式出力以外のとき、このオプションは無視されます。
ex). /4gbok=1 ※出す場合は、ex). /4gbok=0
/list=[PATH]
別テキストファイルで暗号/復号処理するファイルリストを指定
ex). /list=C:\Temp\list.txt
※パスに空白が含まれる場合は、
"/list=C:\Documents and Settings\User1\My Documents\list.txt"

指定するファイルリストの書式は、1行1ファイルパスです。
ex).上記のパスに指定したlist.txtの中身↓
hogehoge.bmp
hogehoge1.bmp
hogehoge2.bmp
hogehoge3.bmp
tmp\temporary.htm
C:\Documents and Settings\User1\My Documents\test.doc

※別途実行引数にファイルパスを直接入れても、併用できます（というか一緒に処理されちゃいます）。
※当然ですが、存在しないパスがあると処理中にエラーが発生します。

こうして見ると、引数指定はけっこう煩雑ですが、既存の設定をそのままに、変えたいところだけ一時的に引数指定すると考えて使うとわかりやすく便利かと思います。

たとえば、

"C:\Program Files\アタッシェケース\AtchCase.exe" 企画文書１.doc /p=hirakegoma /ow=1 /exit=1 /saveto=encrypt

とすれば、

「企画文書１.doc」を暗号化するとして、パスワードは「hirakegoma」、上書きの確認無し、処理後終了、保存先は、「encrypt」フォルダとなります。それ以外の未指定の動作設定については、既存の設定が適用されます。


基本設定

アタッシェケースの起動や、動作に関する基本的な設定を行えます。

  • 暗号化パスワードを記憶する

    暗号化する際のパスワードを記憶しておくことで、ファイルをドラッグ＆ドロップした際にパスワード入力無しで暗号化することができます。
    もちろんパスワード自体は暗号化され、あなたのＰＣに保存されます。

    ただし、「空白（文字が何も入力されていない状態）」での記憶はできません。通常の暗号化の際には「空白」のパスワード指定が可能ですが、空白をパスワードとして「記憶させる」ことはできません。これはセキュリティーを考慮しての仕様です。

    暗号化したデータを自分のＰＣ間で持ち運ぶだけで、ＰＣ上ではファイルを自由に運用したいというときに便利です。しかし、記憶パスワードが暗号化されるとはいえ、ＰＣ上に記憶されるので、セキュリティーは万全ではないことを留意してください。（→パスワードを記憶するリスク）

  • 復号化パスワードを記憶する

    同様に復号化の際のパスワードを記憶します。
    むしろ、暗号化の際だけ記憶しておき、復号化の際は記憶せず「手入力」にしておけば、割にセキュリティーを保ちつつ簡便にファイルの管理ができるようになります。

    • Tips!

      暗号化/復号化パスワード欄に直接、ファイルをドラッグ＆ドロップすることで、そのファイルのSHA-1ハッシュ値をパスワード文字列として記憶することもできます。

      "*"が表示されている（暗号、復号それぞれの）パスワード文字列欄へ任意のファイルを直接ドラッグ＆ドロップします。パスワード文字列には、そのファイルのSHA-1ハッシュ値が記憶されます。

      暗号化パスワードを「ファイル」で記憶しておいて、復号時にパスワードファイルを直接ドラッグ＆ドロップしたいという場合に設定します。

  • 記憶パスワードで確認なく実行する

    チェックをすると入力された記憶パスワードで、確認を行わず即座に暗号/復号処理へ移行します。
    記憶パスワード入力があり、チェックを外した場合は、テキストボックスにパスワードが入力された状態でいったん処理が止まります。その際に、元ファイルの削除、実行形式出力選択を行うことができます。

  • フォルダの場合、復号後に開く

    チェックすると、Explorerで復号化したフォルダを開きます。

  • 復号化したファイルを関連付けられたソフトで開く
    復号化した後、単一のファイルであれば、そのまま関連付けられたアプリケーションソフトで開きます。

  • 処理後、アタッシェケースを終了する

    チェックすると、暗号／復号化を行った後にアタッシェケースを終了します。

  • デスクトップで最前面にウィンドウを表示する

    チェックを外すと、他のアプリウィンドウに隠れるようになります。通常のアプリケーションウィンドウと同じスタイルにしたい場合にチェックを外してください。

  • 「*」で隠さずパスワードを確認しながら入力する

    チェックを入れると、パスワード入力の際に、「********」などと隠さずにパスワード文字列を確認しながら入力することができます。

  • 常に自己実行形式で出力する

    チェックを入れると、暗号化ファイルは常に自己実行形式（*.exe）で出力されるようになります。

  • メインフォームにチェックボックスを表示する

    チェックを入れると、メインウィンドウに「実行形式出力」のチェックボックスが表示されます。
    ファイルを暗号化するときに、実行形式にするかどうかを選択できます。

  • 暗号/復号処理かを問い合わせる

    通常、アタッシェケースは投げ込まれたファイルまたはフォルダを自動で判断して、暗号か復号かの処理を決定しています。しかし、このオプションにチェックを入れることで処理開始時に問い合わせることができます。
    「暗号化」が選択されれば、暗号化ファイル（*.atcなど）を除いたファイル/フォルダを選んで処理します。
    「復号化」が選択されれば、逆に投げ込まれたファイル/フォルダから、暗号化ファイルだけを選んで処理します。

  • 複数起動しない

    チェックを外すと、アタッシェケースを複数起動することができます。複数のファイルを同時並行で処理したいときなど便利です。
    たとえば既にアタッシェケースを起動した状態で、ショートカットアイコンへファイルなどをドラッグ＆ドロップすると、もう一つのウィンドウが立ち上がり、そちらで別途処理されることになります。


パスワードを記憶するリスク

パスワードを「記憶する」にチェックすると、あなたのパソコンのシステムに記録して、次回からパスワード入力無しで、暗号／復号化を行うことができます。たとえば、データを自宅－会社間で持ち運ぶなどに便利な機能です。

記憶するパスワードにも、しかるべき暗号化を行ってから保存していますので、容易に記憶パスワードが盗まれることはありません（あなたのＰＣでしか記憶パスワードを読み出せない仕組みにしています）。ただ、これは必ずしも安全とは言えません。第三者があなたのＰＣにあるアタッシェケースを使って、復号化すれば簡単にファイルは盗み見できてしまいます。

なので、データの持ち歩きの際だけ、流出を防げればいいといった以外は、安全性を高めるため、毎回パスワード入力することをお勧めします。


SHA-1ハッシュ値をパスワードとして記憶する

"*"が表示されている（暗号、復号それぞれの）パスワード文字列欄へ任意のファイルを直接ドラッグ＆ドロップします。パスワード文字列には、そのファイルのSHA-1ハッシュ値が記憶されます。

暗号化パスワードを「ファイル」で記憶しておいて、復号時にパスワードファイルを直接ドラッグ＆ドロップしたいという場合に設定します。


保存設定

アタッシェケースで作成する、暗号化ファイルや復号したファイルなどの保存・上書きに関する設定を行えます。

  • 常に同じ場所へ暗号化ファイルを保存する

    バックアップファイルへ保存しているとか、ＭＯなどのメディアに必ずコピーして持ち歩いているというときに指定しておくと、直接そこへ暗号化ファイルを作るので便利です。チェックが外されていると、暗号化ファイルは通常、元ファイルのある同じフォルダに生成されます。
    • Tips
      指定のパスに以下の省略書式を挿入すると、暗号化ファイルを保存する際に、自動で特定のパスへ差し替えることができます。

      <Desktop> | 「デスクトップ」フォルダ
      <My Documents> | 「マイドキュメント」フォルダ
      <Program Files> | 「Program Files」フォルダ
      <AttacheCase> | アタッシェケースの実行ファイル（AtchCase.exe）があるフォルダ
      <volume:*****> | 指定のボリュームラベル名（*****）を持つドライブ

      たとえば、「<DeskTop>\temp」と指定すれば、デスクトップにあるtempフォルダ内を常に保存する先として認識します。

      また、「<volume:MOBILE>\」と指定したとき、抜き差し可能なフラッシュメモリで、常にドライブレターが変わるようなとき、そのフラッシュメモリのボリュームラベル名を指定しておくだけで、暗号化の際に自動で該当のドライブを探してパスを補完します。

      たとえば、差されたフラッシュメモリが「H:\」とWindowsによって認識され、ボリュームラベルが「MOBILE」とするとき、暗号化ファイルを常に保存する場所を「<volume:MOBILE>\temp」とだけ指定しておけば、作成される暗号化ファイルは、

      H:\temp\暗号化ファイル.atc

      として保存されることになります。フラッシュメモリを差したタイミングによって、「H:\」ドライブが変わってしまったとしても、正常に保存することが可能です。なお、指定の保存先がない場合は、エラーメッセージが出て、暗号化処理を終了します。

  • 常に同じ場所へファイルを復号化する
    前項のオプションと同様に、復号化したファイルを常に同じ場所へ保存したいという場合にチェックします。暗号化されたデータは持ち運ぶMOなどのメディアへ送り、復号化したファイルは常に「マイ ドキュメント（My Documents）」へ置いておきたいという場合に便利な機能です。
    • 「常に同じ場所へ暗号化ファイルを保存する」と同様に、"<Desktop>"などの書式を指定すると、その場所へ復号したファイルを生成することができます。

  • 同名ファイルがある場合は上書きの確認をする

    暗号/復号化の際、すでに同じ名前のファイル（またはフォルダ）が作成先にある場合、確認のメッセージを表示します。チェックを外すと、そのまま確認無しで上書きが行われます。

  • 複数ファイルの処理

    複数のファイルをアタッシェケースで処理するときのオプションを指定します。
    通常通りの動きを期待する場合は、「何もしない」を選択します。

    • 何もしない

      複数のファイルやフォルダをアタッシェケースにドラッグ＆ドロップなどすると、それぞれを暗号化しファイルが生成されます。
      フォルダの場合は、サブフォルダも含め、フォルダ単位でパックされます。

    • 複数ファイルは一つの暗号化ファイルにまとめる

      複数のファイルやフォルダをアタッシェケースにドラッグ＆ドロップなどすると、１つの暗号化ファイルとしてまとめます。
      このオプションを選択している場合、暗号化の際には、新しくつけるファイル名を指定します。

    • フォルダ内のファイルは個別に暗号化/復号する

      フォルダがアタッシェケースへドラッグ＆ドロップなどされた場合、サブフォルダ以下にあるファイルすべてを個別に暗号化します。

      また、このオプション選択中に限って、暗号化ファイルを含むフォルダをアタッシェケースへドラッグ＆ドロップなどした場合に、サブフォルダ以下にある暗号化ファイルすべてを復号しようと試みます。

      （※ただし、該当のフォルダ内に通常ファイルなどが混じっている場合は、暗号/復号処理が入り乱れますので注意が必要です。暗号/復号後に元ファイル削除するなどのオプション指定をしておくと良いでしょう。）

  • 復号するときに親フォルダを生成しない

    フォルダを含むデータを暗号化した場合、復号時にその親（基本）フォルダを生成するかどうかを選択できます。チェックすると、フォルダ内にある（複数の）ファイルを暗号化ファイルのある場所へそのまま復号します。複数ファイルをまとめて暗号化した際に、付けた名前でフォルダを生成したくない場合に、便利なオプションです。

  • 暗号化ファイルのタイムスタンプを元ファイルに合わせる

    出力する暗号化ファイル（*.atc/*.exe）のタイムスタンプを、元ファイルのタイムスタンプに合わせます。複数ファイルを一つにまとめて暗号化する際には、一番最初に処理するファイル/フォルダのタイムスタンプに合わせられます。
    • ただし、Win95/98系でアタッシェケースをご使用し、フォルダを暗号化した際は、タイムスタンプは生成した日時に設定されます。

  • タイムスタンプを復号化した日時に合わせる

    各ファイルのタイムスタンプ（更新日時）は、暗号化してもそのまま変更されず保持されますが、復号化した時の日時へ強制的に合わせたい場合は、チェックをします。ファイル管理をタイムスタンプで行っている上級者向けの機能ですので、基本的にはチェックする必要はありません。

  • 暗号化ファイル名に拡張子を含める

    チェックを入れることで、生成する暗号化ファイルの名前に、元ファイルの拡張子を含めるようになります。

    たとえば、

    新しい企画案.doc　　新しい企画案.xls

    というファイルが２つあって、同時に暗号化しようとすると、どちらも「新しい企画案.atc」となって２つは同時に暗号化できませんが、このオプションをチェックすることで、

    新しい企画案.doc.atc　　新しい企画案.xls.atc

    といったように、元のファイル拡張子をそのまま残して暗号化ファイルを作ります。
    暗号化の際のファイル名重複を避けることができます。

  • 自動で暗号化ファイル名を付加する

    チェックして、あらかじめ書式を指定しておくことで、いつも決まった規則で暗号化ファイルの名前を付けることができます。

    指定できる項目は、以下の通りです。

    作成する暗号化ファイル名が「EncodeFile.atc」だとして...

    ・ファイル名 | 例）　EncodeFile
    ・拡張子 | 例）　.atc
    ・日付 | 例）　EncodeFile[2004年2月1日].atc
    ・連番 | 例）　EncodeFile[000].atc～EncodeFile[999].atc
    ・ランダムな文字列 | 例）　fKUSup'}.atc
    ・先頭からのファイル名 | 例）　Enco
    ・末尾からのファイル名 | 例）　File

    挿入する書式は、それぞれ<>かっこで指定します。
    ・ファイル名 | <filename>
    ・拡張子 | <ext>
    ・日時 | <date:[指定書式]>
    ・連番 | <number:[桁数]>
    ・ランダムな文字列 | <random:[文字数]>
    ・ファイル名先頭文字列 | <fhead:[文字数]>
    ・ファイル名末尾文字列 | <fend:[文字数]>

    これらを組み合わせて指定することで、常に自動で付けるファイル名規則を指定します。
    なかなか難しいかとは思いますが、フォーム上にサンプル表示されますので、入力しながらいろいろ試してみてください。

    【日時】
    たとえば、<date:yyyy_mm_dd>と、date: の後に書式を指定することで、現在の日時を挿入することができます。

    挿入できる詳しい書式については、「日付書式例」を参照ください。

    現在日時が 2004/2/1 15:03:42 だとして、以下の指定を行うと、

    <date:yyyy_mm_dd>

      ↓

    2004_02_01

    <date:yymmdd-hhnnss>

      ↓

    040201-150342

    などと置き換えられます。

    【連番】
    たとえば、<number:3>と number: の後に数字を指定することで、挿入する通し番号の桁数を指定できます。

    作成されるファイル名が「sample.atc」だとすると、

    <filename><number:3><ext>

    と指定することで、「sample001.atc」から順にナンバリング、sample002.atc，sample003.atc…と連続して作成されます。

    この「連番」書式は、使い方によっては便利な機能です。自動的に欠番を探して、重複がないようにファイル名を付けて作成していくので、いちいち上書きの確認がありません。暗号化ファイルを連続して作成して版管理したり、バックアップとして使用することができます。

    【ランダムな文字列】
    たとえば、<random:8>と、random: の後に数字を指定することで、その文字数分ランダムな文字列を挿入することができます。

    <random:8><ext>

    として作成すると、

    MA[vV}e7.atc

    といった、その都度ランダムな文字列（英数字、記号から）を生成、組み合わせてファイル名を作ります。

    ファイル名から中身を類推されるのを防いだり、隠蔽したいときに便利な機能でしょう。ただし、これをやると元ファイル名が、暗号化ファイルからはまったく分からなくなるので、管理には十分注意が必要です。

    【ファイル名先頭/末尾文字列】
    たとえば、生成されるファイル名が「EncodeFile.atc」とします。<fhead:4>と、fhead: の後に数字を指定することで、ファイル名を先頭からその文字数分だけ抜いた名前を付けることができます。

    <fhead:3><ext>

    として作成すると、

    Enc.atc

    同様に、

    <fend:4><ext>

    と指定すると、

    File.atc

    となります。


日付書式例

日時で指定できる書式は以下の通りです。

d | 日付文字先頭にゼロを含めないで表示。1～31
dd | 日付文字先頭にゼロを含めて表示。01～31
ddd | 曜日の省略形。日～土
dddd | 曜日。日曜日～土曜日
aaa | 曜日の省略形。日～土
aaaa | 曜日。日曜日～土曜日
dddddd | 日付を標準形式（2004年1月31日）と表示。基本的には、「yyyy'年'mm'月'dd'日'」とやっても同じ。
m | 月文字先頭にゼロを含めないで表示。1～12 hhの直後に指定すると、分として表示される。
mm | 月文字先頭にゼロを含めて表示。1～12 hhの直後に指定すると、分として表示される。
mmm | 月の省略形。1～12 (※英語版なら、Jan～Decと表示)
mmmm | 月を標準形式で表示。1月～12月
yy | 年を２桁で表示。00～04
yyyy | 年を４桁で表示。0000～2004
h | 時にゼロを含めないで表示。0～23
hh | 時にゼロを含めて表示。00～23
n | 分にゼロを含めないで表示。0～59
nn | 分にゼロを含めて表示。00～59
s | 秒にゼロを含めないで表示。0～59
ss | 秒にゼロを含めて表示。00～59
am/pm | 午前なら「am」と、午後なら「pm」と表示。「AM/PM」と指定すれば大文字で表示。
a/p | 午前なら「a」と、午後なら「p」と表示。「A/P」と指定すれば大文字で表示。
ampm | 「午前」「午後」と表示。

' '（シングルコーテーション）、" "（ダブルコーテーション）で囲まれた文字はそのまま表示します。
上記の書式には影響を与えません。たとえば、こんなふうにやります。「yyyy"年"mm"月"dd"日"」。

また、日付を区切るときに使う /（スラッシュ）や、時間を区切るときに使う : （コロン）は、Windows上でファイル名として使うことができない「禁止文字」ですので、指定の際は、ご注意ください。

  • 禁止文字
    ファイルパスやワイルドカードなどでWindowsが使用するため、以下の文字はファイル名として付けることができません。

    \ / : , * ? " < > |


削除設定

アタッシェケースで暗号/復号化した際に、元ファイルを削除するかどうか、またその削除方法についての設定を行えます。

  • 暗号／復号化した後、元ファイルを削除する

    チェックすると、処理を行った後に、ファイルを削除します。具体的な削除方法については、以下の項目のいずれかを選択します。

  • 通常削除を行う

    アタッシェケースの独自機能である「完全削除」を行わず、通常のファイルと同じく削除します。
    ただし、Windowsの「ごみ箱」への削除ではありません。ややこしいですが、Windowsで言うところの完全削除となります。ご注意ください。

  • インフォームにチェックボックスを表示する

    チェックを入れると、メインウィンドウに「削除」のチェックボックスが表示されます。
    ファイルを暗号/復号化するときに、削除するかどうかを選択できます。

  • ごみ箱への削除を行う

    Windowsのごみ箱への通常削除を行います。
    ただし、メッセージでの問い合わせは行いませんので、即座に、ごみ箱行きとなります（^^;

  • 完全削除を行う

    アタッシェケース独自の「完全削除」を行います。ファイルを暗号化した際に、市販のユーティリティソフトなどによって、元ファイルを復活されないように削除することができます。「完全」の度合い（これもおかしな言い方ですが…（^^;））は、以下で設定することができます。

    • 乱数の書き込み回数（0～99）
      ファイルを乱数（でたらめな数値）で、埋め尽くして上書きします。
      それを何度繰り返すかを指定できます。0にすると行いません。

    • ゼロ書き込み回数（0～99）

      乱数を書き込んだ後に、ゼロで埋め尽くして上書きします。
      それを何度繰り返すかを指定できます。0にすると行いません。

    処理するファイルサイズが大きく、また回数を多くすれば多くするほど、時間がかかります。基本的に完全削除することは難しいので（→元ファイルの削除方法について）、あまり神経質になる必要はないでしょう。初期設定の値で十分だと思います。万全を期したい場合は、市販の削除ユーティリティソフトを使うことをお勧めします。


動作設定

アタッシェケースで作成する暗号化ファイルの圧縮率の設定や、復号時にきちんとファイルが正常に戻っているか確認するためのコンペア設定を行えます。

圧縮する
チェックをすると、暗号化の際にデータ圧縮を行います。

また、スライダバーを調節することで、圧縮率を設定できます。

初期設定では、<6>になっています。

圧縮率を大きくするほど、暗号化したファイルサイズが小さくなりますが、処理に時間がかかります。その辺はユーザーさんの用途に応じて使い分けてください。

0～9の間で圧縮率の設定ができます。

基本的にはzlibライブラリ（別作者による圧縮プログラム）の仕様に則した設定値となっています。

< 0 > に設定すると、圧縮を行いません。
< 1 > はスピード重視で圧縮処理を行い、< 9 > は圧縮率重視で処理を行います。
< 6 > は、スピードと圧縮率がバランス良く設定された推奨値です。

アタッシェケースへ組み込む前に、各段階で圧縮解凍してテストしましたので、段階によって復号化できなくなるということはありません。

また、圧縮率はデータ内容に依存しますので、データの種類によってはあまり圧縮も効かず、実感としてスピードもあまり変わりがない、ということもあります。
暗号化した後にデータのコンペアを行う
ファイル、またはフォルダを暗号化した後に、元データとコンペア（データ比較）を行い、正しく復号できているかどうかをチェックします。バックアップファイルなど、大事なデータとして暗号化したい場合に設定しておくと安心です。

ただし、暗号化したファイルをメモリ上で馬鹿正直に復号化処理を行ってからコンペアをとっていますので、非常に時間がかかります。暗号と復号の処理を１セットで行うのと同じと考えてください。ハードディスク等へ書き込まない分だけ、ちょっと速いくらいでしょうか。

なお、元ファイルの完全削除設定をしている場合には、コンペアが行われた後に削除実行されます。


システム

システム設定

アタッシェケースとの関連付けや、ファイルアイコンの変更などシステム（Windows）に関わる設定を行えます。

  • システム設定
    • 暗号化ファイル（*.atc）の関連付け設定

      ボタンを押すことで別のプログラム（AtcSetup.exe）が呼び出されて、Windowsのファイルシステムにアタッシェケースファイル（*.atc）を関連付けします。
      ただし、WindowsNT/2000/XPにおいて制限ユーザーなどでログオンしていると、この設定は有効になりません。関連付けを有効にしたい場合は、一度管理者権限にしてから行う必要があります。
      また、Vistaの場合においても管理者権限で実行する必要があります。

    • 暗号化ファイル（*.atc）の関連付け解除

      ボタンを押すことで別のプログラム（AtcSetup.exe）が呼び出されて、Windowsのファイルシステムからアタッシェケースファイル（*.atc）の関連付けを解除します。
      ただし、WindowsNT/2000/XPにおいて制限ユーザーなどでログオンしていると、解除されません。
      また、Vistaの場合においても管理者権限で実行する必要があります。

    • 「送る」フォルダにアタッシェケースを追加

      ボタンを押すことで、Windowsの「送る（SendTo）」フォルダにアタッシェケースのショートカットファイルを追加します。ファイルを右クリックしたときに出る「送る」メニューに入ります。

  • ファイルアイコンの変更

    デフォルトの関連付けられたアタッシェケースファイル（*.atc）のアイコンを変更することができます。
    任意のアイコンファイルをユーザー自身が読み込ませて設定することもできます。鍵付きの、いかにも暗号化ファイルでございます、という現在のアイコンから、たとえばテキストファイルアイコンにしたり、画像ファイルアイコン等にすれば、「暗号化して隠している」ということさえも第三者に知られることがなくなります。

  • 動作設定の保存
    • 現在の動作設定を出力する

      現在の動作設定を、コマンドラインオプションとして、INIファイル、バッチファイル、テキストファイルなどに出力して保存することができます。別スクリプトファイルなどを作成するときのベースとして使えます。

      なお、INIファイルとして出力し、実行ファイルやカレントディレクトリに置くことで、一時設定でアタッシェケースを起動することできます。
      →詳しくは、「.INIファイルの活用方法」のページを参照ください。

    • 一時設定をメイン設定に置き換える

      コマンドラインオプションから起動したときの一時設定を、メインの設定に置き換え、保存します。
      ただし、保存されるタイミングはアタッシェケースが終了したときです。
      ちなみに、通常起動したときにはボタンは無効になっています（押せません）。


高度設定

高度な設定

アタッシェケースをより高度な設定をすることで、面白い使い方ができます。

  • パスワードファイル
    • パスワードにファイルの指定を許可する

      チェックすることで、パスワード入力のウィンドウになったとき、文字列を入力する代わりに任意のファイルをドラッグ＆ドロップすることで、「パスワード」の代わりとすることが可能になります。

      内部的には、投げ込まれたファイルの縮約した小さな固有データ（160bit）を生成し、それをパスワードとしています。
      なお、ファイルの縮約するメッセージダイジェストアルゴリズムにはSHA-1を使用しています。

      たとえば、Word文書を暗号化する際に、My Picruesフォルダなどにある写真画像（*.jpg）をパスワードとして指定すれば、隠蔽効果が高まります。パスワード文字列を類推される恐れもなくなりますし、さらにパスワードファイルを別の場所（外部メディアなど）に避けておけば、セキュリティー効果が高まります。

      しかし、もしパスワードとして指定したファイルを削除したり、編集・上書き保存してしまった場合は、パスワードが失われることになります（^^;

      たとえ、一文字（あるいは1byte）でも変更を加えてしまったとしても、縮約されたデータは大きく変わる性質を持っています（→詳しくは「SHA-1について」を参照してください）。パスワードに指定したファイルは、「全体」がキーそのものになっているとお考えください。

      使い方を誤るとデータを失うなど、たいへん危険な機能ですので、十分注意し、自己責任で設定してください。パスワードとして指定するファイルはあらかじめ属性を「読み取り専用」にしておくなどの対策をしておいた方がいいでしょう。

    • 暗号時にパスワードファイルを自動チェックする
    • 復号時にパスワードファイルを自動チェックする

       ここをチェックすると、指定のパスワードファイルを読み込み、そのまま自動で暗号/復号化するようになります。
      暗号時と復号時それぞれで、同じパスワードを使う場合は、両方に同じファイルパスを指定します。

      パスワードファイルを、外部メディア（ＦＤやUSBフラッシュメモリ等）に保存しておけば、擬似的な物理キーとしても機能します。

      USBフラッシュメモリに指定のパスワードファイルを保存して持ち歩き、
      暗号/復号化のときだけ差し、そこをチェックさせて使えば、
      擬似的な物理キーとしても機能します。

      直接そのファイルを読み込み、パスワードとして設定します。
      ただし、パスワードファイル名がそのものズバリここに表示されることになります。他の人が勝手にアタッシェケースを起動し、この設定パネルを見てしまえば、パスワードファイルの在処は丸見えです。ＰＣ上でのセキュリティーを保ちたいのであれば、扱いには注意が必要です。

      パスワードファイルの所在はもちろん、ファイル名まで丸見えです．．．

      いずれにせよ、常に取り外す外部メディアではなく、ローカルにあるファイルを指定するのはセキュリティー上、オススメはできません。

    • ファイルがない場合エラーメッセージを表示しない

    チェックすると、所定の場所にパスワードファイルがなかった場合でも、エラーメッセージを表示しないようになります。

  • 拡張子偽装
    • 暗号化ファイルの拡張子を偽装する

      常に作成される暗号化ファイルの拡張子は、指定の拡張子になります。
      ドットも含めて指定します。　.txt　といったように。

      いかにも単純な偽装オプションですが、ちょっとした隠蔽効果は期待できると思います。

      拡張子はちがえど、中身はアタッシェケースファイルです。復号化の際には、そのままアタッシェケースへドラッグ＆ドロップなどで読み込めば、問題なく復号することができます。ただ、関連付けはとうぜん利きませんので、ファイルの扱いには注意が必要です。

      たとえば拡張子が、*.txtのまま開くと、めちゃくちゃな文字列として表示されます。拡張子に関連付けられたアプリケーションによっては、読み込み時に不具合を起こすかもしれません。

      また、そのファイルがアタッシェケースファイルであることを忘れてしまってもアウトです（^^;
      この機能を使うときにも、十分注意し、自己責任でお願いします。


INIファイルの活用方法

アタッシェケースでは、レジストリとは別に.INIファイルとして設定を保存することができます。 また、作成したその.INIファイルを個別に読み込むことで、動作設定を起動時に切り替えることが可能です。

暗号化ファイルを各所の異なるPCで復号しなくてはならない場合や、 アタッシェケースのインストールされていない環境へUSBフラッシュメモリなどで持ち込む場合など、 常に自分好みの設定でアタッシェケースを起動したい方には便利な機能です。
  • INIファイルとは
    アプリケーションの設定情報を書き込むテキスト情報のことです。 拡張子こそ".ini"となっていますが、中身はテキストファイルです。 よってエディタなどでユーザー自らの編集が可能ですが、誤って 変更すると動作の保証ができなくなるので扱いには注意が必要です。 アタッシェケースでは、iniファイルではなく、Windowsのシステム （レジストリ）に設定情報を保存していますので、 そもそもこの ファイルは不要ですが、設定情報を他のPCへ持ち出したいときや、 処理ごとに設定を替えて切り出しておきたい場合に、INIファイル として保存して利用すると便利です。
  • .INIファイル作成の仕方

    動作設定の「システム」タブを開き、「現在の動作設定を出力する」ボタンを押します。↓

    .INIファイル形式を選択して、「_AtcCase.ini」というファイル名で出力します。
      ここに現在の設定内容がすべて書き出されます。↓

  • .INIファイルの読み込み方法

    前の項目で出力した.INIファイルの設定内容で起動したい場合は、 「_AtcCase.ini」ファイルを以下の場所に置いてアタッシェケースを起動する必要があります。
    • カレントディレクトリ
    • アタッシェケース本体（AtchCase.exe）のあるディレクトリ
    • 処理したいファイルや暗号化ファイルのあるディレクトリ

    上記の順番で「_AtcCase.ini」ファイルを探索し、見つかったときに読み込まれますので、 複数箇所にINIファイルが置かれると、予期しない設定動作になることがあります。
    通常、何もせずに（設定のINIファイルをどこにも置かずに）アタッシェケースを起動すると、 レジストリにある設定内容で起動します。

    アタッシェケース本体のある場所に.INIファイルを置きます。↓

    あるいは処理するファイル/または暗号化ファイルの横に.INIファイルを置きます。↓

    後者の場合、ファイル/暗号化ファイルは、直接アタッシェケースアイコンにドラッグ＆ドロップするか、 関連付け起動する必要があります（起動してからファイルをドロップしても、 そのディレクトリにある.INIファイルを参照しないので注意が必要です）。

    そうすることで、一時的に.INIファイルの内容で動作設定が行われ、アタッシェケースは起動します。

    なお、「_AtcCase.ini」のファイル名は固定です。 名前は変更しないでください。アタッシェケースは、設定ファイルを中身ではなく、そのファイル名で判断し読み込んでいます。

  • .INIファイルの内容を現在の設定に反映したいとき

    前述の方法で、設定した.INIファイルを読み込んでから、 動作設定の「システム」タブを開き、「一時設定をメイン設定に置き換える」ボタンを押してください。

    そうすることで、.INIファイルの内容がレジストリへ読み込まれ、メイン設定として上書きされます。


パスワードを忘れてしまったら

どうにもなりません。あきらめてください（笑）。

しばしばメールをいただきますが、作者でも解読不可能です。パスワード文字列は、鍵として暗号化ファイルにそのまま含めているわけではありません。暗号化する際のシャッフルの「素」として使っています。イメージとしては料理に入れる「調味料」と同じで、完全に溶けて素材と混ざり合っている状態です。

ということから、あなたが一度パスワードを失念すると、パスワードを抽出することも、混ざり合ったファイルを元に戻すことも不可能となります。暗号強度の高さは折り紙つきですし、作者においても解読不可能なのはいわずもがな。

そもそも誰かが解読できるような暗号化ソフトだったら、意味ありませんよね？（^^;

しかし、それでもどうにかして解読したいという方がいるかもしれません。その場合は、唯一「パスワードの総当たり」を行う方法があります。アタッシェケースでは、コマンドラインオプションが使えますので、スクリプトやバッチファイルを組むなどして力業で解くのです。プログラムの知識が多少あれば、すぐに組むことができるでしょう。

  • スクリプトやバッチファイル
    パスワード総当たりスクリプト スクリプトについては、WordやExcelに付属するVBAマクロや、 Windows Scripting Hostなどがあります。スクリプトやバッチ ファイルの作り方については、ネットなどでお調べください。 『アタッシェケース』の範疇ではありませんし、サポート外です。 作者へ問い合わせても対応いたしません。あしからず。

ただ、これにも限界があります。入力したパスワード文字数が多いと、組み合わせ数が増加します。また、全角入力（漢字など）されていると、爆発的に組み合わせ数が増えます。解読にはおそろしく長い時間を要するでしょう。あなたが忘れたパスワードを思い出す方がよっぽど効率的で、解読確率が高いということになるかもしれません。

逆に言えば、パスワード管理をきちんと行うということを前提で、第三者によって破られにくい暗号化ファイルを作るには、「パスワードの総当たり」攻撃に耐えうるよう、パスワードを考えて入力するべきだとも言えます。長い文字列を入力する、全角文字列にする、パスワードファイル機能を使うなど、いろいろ工夫するべきでしょう。


アタッシェケースの弱点

強力な暗号アルゴリズムを使っているとはいっても、「アタッシェケース」には弱点があります。その辺を十分に考慮した上で、ご使用ください。

社外秘など、漏洩してはまずいファイルなどは、「アタッシェケース」を使わず、あなたの会社のしかるべきセキュリティー規則で運用するのが無難です。作者自身が言うのもなんですが、完全なセキュリティー保証はできません。それがフリーソフトウェアの限界ですし、作者は一切の責任を負いません。

ただ、以下の弱点を考慮した上で運用する分には、ある程度のセキュリティーを保って、アタッシェケースを使うことができます。暗号の仕組み自体は強力なものですから。

  • パスワードが漏れる

    アタッシェケースでパックしたファイル（*.atc）は、まず破られることはありません。暗号アルゴリズムのRijndael（またはBlowfish）はそれだけ信頼性があります。暗号化したファイルをフロッピーディスクや、ＭＯディスクに入れて持ち歩いていて、万一紛失してしまっても、拾った人が解読することはまず不可能です。

    しかし、拾った（あるいは盗んだ）人がアタッシェケースをインストールしていて、かつあなたが入力したパスワードを知っていれば別です。当たり前ですけども（^^;）。 基本的なことですが、パスワードの管理には十分に気をつけましょう。

  • 別のアプリケーションが編集中に作ったバックアップファイルから漏洩する

    他のアプリケーションで編集中に、アタッシェケースを使って暗号化したとき、バックアップファイルを残してしまう場合があります。バックアップ機能があるワープロソフトや、テキストエディタなどをお使いの場合には要注意です。アタッシェケースには、別アプリケーションの動作を監視するまでの機能はありません。暗号化する前に、それらが残っていないかを確認する必要があります。

  • ハードディスクを盗まれファイル復旧ユーティリティーで復活される

    暗号化しても、ハードディスクを盗まれるかして、いわゆる市販のファイル復旧ユーティリティーなどが使われれば、暗号化される前のファイルを復活される可能性があります。ただ、それに対する対策は一応施してはありますが、万全ではありません。（→元ファイルの削除方法について）

  • パソコンが第三者によって監視されている

    あなたが打ち込んだキーや、マウス操作などを監視するソフトを第三者によって密かにインストールされていれば、容易にパスワードは漏洩します。そうそうあることではないと思いますが、そのようなツールがネット上で入手可能であるということも知っておいた方がいいでしょう。


元ファイルの削除方法について

暗号化した際に、元ファイルを削除することもできますが、一応はセキュリティーを考慮した削除方法をとっています。

Windowsでファイルを削除すると、通常ファイルの「住所」だけが消される仕組みになっています。つまり見た目は消えていますが、ファイル本体はハードディスク上に残っているということになります。これを、市販の復旧ユーティリティーソフト等が見つけ復活させるわけです。

そこでアタッシェケースでは、削除する前にそのファイルサイズ分、乱数（めちゃくちゃな数字）で書き込み、さらにNULL文字（空文字）で同様の上書きを行っています（「オプション」で、その書き込みの回数や方法は指定できます）。さらにその後、ファイルサイズを 0 にしてから、ようやく削除しています。

なので、たとえファイル復旧ユーティリティーで復活を試みても、サイズが 0 になったファイルが見つかるか、NULLで埋め尽くされた断片がいくつも見つかるだけになるかと思います。

ただ、これも完全ではないようです。まれにファイルの一部が別のところに書き込まれ、残ってしまうこともありますし、2000/XPでは暗号化ファイルを初めとして、完全削除は仕様上、たいへん難しくなっています。優秀なツールを使い、大量の時間をかければ、解析と復活は可能でしょう。

セクタ単位でディスクを解析して、直接書き込むなどの方法も考えましたが、作者に、物理ドライブアクセスを安全に行うほどのプログラミング能力がないのと、たとえ実現したとしても、処理に膨大な時間がかかります。セキュリティー「コスト」を考えると、わざわざそこまでするソフトでもないかなと判断し、採用は見送っています。

基本的には、元ファイルは「完全に削除できない」と考えてください。
ある程度の復活を防ぎ、解析しにくくはするという程度の代物です。

もしもファイルを厳重に管理したいのであれば、削除には市販の削除ユーティリティーを使うか、元ファイルの残骸が意図しない形で残らぬよう、リムーバブルメディア（FDや、MOなど）上で暗号処理をせず、きちんとローカルで行ってからコピーするなどの対策が必要でしょう。


暗号化アルゴリズムについて

『アタッシェケース ver.2』では、暗号化アルゴリズムとして「Rijndael（ラインダール）」を使用しています。

Rijndaelとは、ベルギーの数学者 Joan Daemen氏と Vincent Rijmen氏によって開発された新しい暗号アルゴリズムで、2000年10月にアメリカ政府標準技術局（NIST）によって、次世代の暗号化標準 AES（Advanced Encryption Standard）として選定されたものです。一般公募として行われ、その他の暗号アルゴリズム最終候補（ファイナリスト）としては、Twofish, RC6, MARS, Serpent があります。

それまでは、IBMが開発したDESと呼ばれる暗号アルゴリズムが広く使われていましたが、コンピュータの著しい性能向上や、アルゴリズムの解析が進むことにより、強度が心許ないものになってしまいました。新たな暗号アルゴリズムを採用する必要が出てきたのです。そこへ現れたのが、AES（Rijndael）です。

「Rijndael」の特徴としては、鍵とブロックの長さをそれぞれ128, 192, 256ビットの中から指定できるようになっており、さらに拡張することも可能です。AESではブロック長に限って128ビットの固定と規定されていますが、アタッシェケースでは取り得る最大の256ビットを使用しています。

また、その他ファイナリストの暗号化アルゴリズムにあるような、暗号化中のビット変換をFeistel構造（ファイステルネットワーク）という一般的なアルゴリズムで行うのではなく、SPN構造といった３つの異なる独自変換を行うことで、強力な暗号化を実現しています。

AESは、仕様が公開されていることが原則です。そのため、誰でもが無料で利用でき、自由にソースへ組み込むことができるのはもちろんですが、世界の研究者たちが常に検証を行っていますので、暗号強度については折り紙付きです（たとえ破られたとしてもすぐに情報が得られます（^^;））。また、AESはさまざまなプラットフォーム上で動くことも前提となっていますので、処理速度も高く、優れたアルゴリズムとなっています。

2000年に正式採用されているため、アメリカではDESからAESへの乗り換えがだいぶ進んでいると聞きます。また、日本でもソフトウェアなどへの組み込みが増えてきて、実績も証明されつつあるようです。従来の「アタッシェケース」で採用していたBlowfishでも、まだまだ行けそうですが、この辺で「Rijndael」に切り替えてみることにしました。

AES（Rijndael）についての情報については、以下のサイトで入手することができます。
また、リンクをたどっていけば、様々なプラットフォーム上で動くソースコードが豊富に掲載されていますので、興味のある方は利用されてみてはいかがでしょうか。

アメリカ政府標準技術局（NIST）
- AES Algorithm (Rijndael) Information（英文）
http://csrc.nist.gov/CryptoToolkit/aes/rijndael/

なお、前バージョンで生成したアタッシェケースファイルを復号するため、Blowfish という暗号アルゴリズムも利用しています。これも優れた暗号アルゴリズムですが、ver.2.00以降ではすべてRijindaelを使って暗号化しているため、前データバージョンのファイルを復号する時のみ利用しています。

また、こんなインターネット、ブロードバンドのご時世ですが、個人でも暗号化アルゴリズム（またそれを含むソフトウェア）を海外へ輸出すると、国際条約に違反する恐れがあります。2000年にだいぶ規制は緩和されたとはいえ、アメリカなどが認定するテロ支援国家への軍事目的等の輸出は、今でも法的に罰せられる可能性があります。たぶん明らかな意志で自ら行った場合のみでしょうけども、念のためご注意を・・・（^^;）。

  • テロ支援国家とは
    キューバ、イラン、イラク、リビア、北朝鮮、スーダン、シリア　の７カ国のことです。


暗号のモードについて

前バージョン（ver.1.**）までのアタッシェケースでは、「ECB（electronic codebook：電子符号表）モード」と呼ばれる方式で暗号化していました。単純にブロックごとに暗号化して、そのまま暗号化ファイルに書き込む方法です。図に表すと、以下のような感じになります。

同じファイル、同じパスワードであれば、まったく同じ中身の暗号化ファイルが生成されます。なのでこの方式では、その暗号化の特徴からブロック単位での解読がしやすくなってしまいます。とはいっても、強力なBlowfishで暗号化しているので、そうそう破られるとは思えませんけども・・・

ただ、多少なりとも「検証のしやすさ」という弱点があることは否めません。そこで、『アタッシェケース ver.2』から、「CBC（cipher block chaining：暗号ブロック連鎖）モード」と呼ばれる方式で暗号化することにしました。簡単な図式にすると以下の通り。

上図を見れば明らかですが、まず最初に「初期化ベクトル（Initialization Vector）」と呼ばれる、乱数によるブロックデータを生成します。

これをデータブロックと排他的論理和（XOR）をとってから、暗号化ファイルへ書き込んでいます。

つまり最初の乱数データを元に、データを連鎖的にからめ、巻き上げていくように、暗号化データを生成していきます。この結果、最初に乱数値が与えられることで、同じファイル、同じパスワードで暗号化しても、毎回同じ中身になることはありません。これにより、暗号化特徴からの「検証のしやすさ」の弱点をなくすことができます。

では、最初に乱数を与えて、どうして元に戻す（復号する）ことができるのでしょうか？　それは以下の図の通りです。

最初に与える乱数によるブロックデータも、ファイルに書き込まれているので、元に戻すことができるのです。

では、ファイルにその乱数によるブロックデータが書き込まれてあっても、解析の糸口にされたりしないのでしょうか？

それはできません。暗号化されたブロックデータをまず解析して復号化しない限り、たとえ乱数データが見えていても解析の何の役に立たないからです。乱数データが元となって、このチェインを解きほぐし、解析の端緒にすることはできません。


SHA-1について

「SHA-1」とは、Secure Hash Algorithm-1 の略で、メッセージダイジェストアルゴリズム（Message Digest Algorithm) の一つです。大きなサイズのデータを、固定長の小さなサイズのデータ列に縮約（要約）するためのアルゴリズムです。

同じデータであれば、必ず同じ縮約されたデータになるので、そのファイルの正当性をチェックしたり、パスワードをそのまま保存するのではなく、そのメッセージダイジェストを保存して比較したりするなどして、セキュリティーを強化する目的で使用されます。

ファイルを少しでも編集すると（たとえ１文字変更するだけでも）、まったくちがうメッセージダイジェストが出力されます。たとえれば、そのファイルの指紋のようなもので、固有の値が生成されます。

もちろん、どのような大きなファイル（データ）であっても、160bitという小さいデータに縮約されるので、異なるデータでも同じ結果になることは完全には否定できませんが、その可能性はきわめて低いため、実用上問題ないとされています。

前バージョンまでのアタッシェケースでは、「パスワードファイル」機能において、ファイルの先頭56バイトを抽出していましたが、ファイルフォーマットによっては同内容になることもあり、あまり意味がなかったことから、ver.2 から、SHA-1によってファイルのメッセージダイジェストを求め、それをパスワードとして使うことで、その問題を回避することにしました。（→詳しくは「高度な設定」を参照ください。）

SHA-1の脆弱性について

現在、SHA-1の脆弱性を指摘する論文が提出され、クラックが可能であるとの見解が示されています。しかし実際には天文学的な試行が必要であるということと、アタッシェケースではサブ的な使用になっていることから、現時点で作者としては問題ないと判断しています。さらに、NIST によって、近い将来SHA-1の後継（AHS）を選定する動きもありますので、その新しいハッシュアルゴリズムの登場を待って、アタッシェケースへの採用も考えていきたいと思っています。

  • 天文学的な試行
    １台のＰＣでは1000年以上かかる攻撃方法ともいわれ、 現時点ではごくわずかな政府機関においてでしか、 実用的な攻撃方法ではないとの指摘があります。
  • サブ的な使用
    SHA-1によって作成されたハッシュ値は、見える形で 直接暗号化ファイルに格納されているわけではありません。 暗号化キー、つまりデータを混ぜ合わせる素として使っています。 ということから、そのものをクラックされる危険性はないので、 現時点で問題は少ないと考えています。


国際化対応について

「アタッシェケース」は、ver.1.09から国際化対応を行いました。
手始めに[英語(U.S.）]のみローカライズを行いました。ただし、ヘルプファイルは日本語版のままです。

基本的に作者は、今後積極的な英語版配布を行うつもりはありません。
「知人に日本語のわからない人がいて、その人とやりとりを行いたい」という方のために作ってみたという感じです。

以前あったように、別部品を同フォルダに置くなどの面倒はなくなりました。以下からファイルダウンロードしていただき、解凍してそのままお使いいただけます。ようは、英語版の「アタッシェケース」ということになります。当然、出力される実行形式ファイルも、英語表記として出力されます。ご注意を。

http://homepage2.nifty.com/hibara/software/atcs.htm

なお、国際化対応したことで、他の言語にも対応可能となっています。「英語」以外に需要があるとは思えませんが、他言語にローカライズして使ってみたいという物好きの方はご連絡ください。翻訳していただくメッセージリストを送らせていただきます（^^;

ただ、将来的にバージョンアップしていくと、メッセージも増えていきます。
アタッシェケースがバージョンを上げるかぎり、翻訳作業をお付き合いいただくかもしれません。そのお覚悟でどうぞ（^^;


U3スマートドライブ対応

  • U3スマートドライブについて

    U3スマートドライブとは、米M-Systemsと米SanDiskが設立したU3 LLC社が提唱するUSBフラッシュメモリの標準プラットフォームで、ハード＆ソフトウェア規格のことです。データだけでなく、アプリケーションそのものを持ち運べ、どのパソコンでも利用すること目指しています。

    まだ立ち上がったばかりの団体と規格のため、日本語による詳しい解説がありません。説明は英文となりますが、詳細は以下に。

    http://www.u3.com/

    日本でもようやくU3対応製品が増え始め、U3対応アプリケーションも続々と出てきています。以下のロゴが製品についてUSBフラッシュメモリが、U3スマートドライブです。

    （※通常のフラッシュメモリではU3対応アプリケーションは動作しません。）

  • U3スマートドライブのメリットとは？

    アプリケーションソフトは、WindowsOSに依存して動作するものが多く、抜き差し自由なUSBフラッシュメモリにソフトを入れて持ち歩くというのは、難しい面がありました。またセキュリティー的にみても、ソフトを使用した痕跡が、使ったOSに残るのもよろしくありません。

    そこで、U3スマートドライブに搭載された管理ソフト（U3 Launchpad）から、対応アプリケーションを起動することで、動作設定や各ソフトのプロファイルをWindowsから独立させることが可能になりました。また、起動中はテンポラリフォルダにソフトが展開され、終了時に削除されるので、使ったパソコンに痕跡を残しません。

  • U3に対応したアタッシェケース
    アタッシェケースはすでに、USBフラッシュメモリで持ち運ぶことを想定し、設定を切り離して起動するなどのオプションが豊富に用意されていました。しかし、今回U3に対応することで、より独立したアプリケーションソフトとして動作するようになっています。

    U3対応アタッシェケースは、以下からダウンロードすることができます。
    http://homepage2.nifty.com/hibara/software/atcs.htm

  • インストール

    U3アプリケーションは、専用のU3規格に沿ったUSBフラッシュメモリ上でしか動作しません（ソフトだけでなくハードウェアもU3規格でないと動きません）。まずお使いのUSBフラッシュメモリが、U3対応かご確認ください。

    U3スマートドライブに入っているLaunchpadを起動して「プログラムの追加」をクリック、「マイ コンピュータからのインストール」を選択します。

  • アンインストール

    インストールと同様に、Launchpadを起動して「U3プログラムの管理」をクリック、アタッシェケースを選択して「プログラムの削除」ボタンを押してください。

  • 使用方法

    基本的な使用方法は、通常のアタッシェケースと同様です。このヘルプファイル各ページを参照ください。

    通常のアタッシェケースとちがう点は、動作設定がすべてUSBフラッシュメモリに書き出され、独立して動きます。たとえご使用のパソコンにアタッシェケースがインストールされていても、そちらの動作設定は参照せず、U3スマートドライブ内の設定を参照して起動します。

  • 今後のバージョンアップ

    当面はU3スマートドライブへの対応のみですが、今後はUSBフラッシュメモリ固有シリアル（製造番号）を使って、暗号化するなど、U3スマートドライブ内で完結できるような機能を追加していこうかと思っています。

    また、現在U3スマートドライブのSDKを研究中ですので、もう少しデバイスを直接制御できるような仕組みも追加していきたいなあとは思っています。

    もしも何かご要望、不具合など見つけましたら、お気軽にメールください。


使用条件・免責

使用条件

『アタッシェケース』は、作者自身が仕事上やプライベートで使うソフトとして開発され、せっかく良いソフトができのだから他の方々にも使っていただきたいという想いから、フリーソフトウェアとして公開、配布しています。利用者はそのことを考慮しつつ、下記の免責事項をよくお読みいただいた上で、ご自由にお使いいただけます。

なお、商用利用の場合、「使用」のみであれば、制限なくフリーで利用することができます。会社内で組織的に使う、個人で仕事のサブツールとして使うなどはまったく問題ありません。その際の作者への連絡も不要です（いただければうれしいですが・・・（^^;））。

  • ただし、以下の商用行為は禁止します。
    • アタッシェケース自体（AtchCase.exeなど ）を、商品として販売する
    • 別のソフトウェアにアタッシェケース自体をシステムとして組み込み第三者へ販売する
    • 他製品にバンドルするなど、公開/配布することに対して対価を求める

そういったことを行いたい場合は、別途相談に応じます。事前に必ず作者までご連絡ください。
わかりにくいかもしれませんが、アタッシェケースという「仕組み」を使用するだけなら自由ですが、「仕組み」そのものを売るのは厳禁です。

免責

本ソフトに、たとえバグ（プログラムに不具合）があっても作者はその修正の責任も、義務も持ちません。また、このソフトの使用により発生したいかなる損害に対しても、一切の責任を持ちません。利用者は、このソフトの使用によって発生する全ての事態を想定し、各自の責任にてご使用ください。


転載・再配布

基本的に自由です。どんどん行ってください。
不特定多数の方々へ配布するなど（雑誌収録、別サーバへの転載等）、個人的な枠を越えて行う場合は、事後でも構いませんので、メールでご一報いただければ幸いです。（→連絡先はコチラです）

  • 雑誌エディタの方へ

    雑誌収録の許諾回答を「期待する」メールにはほとんど返信していません。ヘルプをまったく読んでないのでは？と思わせるメールが多いのです（笑）。
    だらだらと型に流し込んだような長文メールを送りつけたりしないように。雑誌収録は前述のとおり「ご一報いただければ」作者の返信なくともO.K.です。

    見本誌を送付していただける場合のみ、その旨をメールでいただければ送付先をお教えいたしますが、メールは簡潔に！　作者に手間をとらせないでね。


著作権・作者について

著作権

本ソフトは、フリーソフトウェアですが、著作権は放棄していません。
『アタッシェケース』の著作権は、ひばら　みつひろ こと、檜原　光博 にあります。

作者について

しばしば聞かれますが、本業はゲームソフトウェア開発（主にコンシューマ機）のお仕事をしています。

よくシステム系ソフトウェア開発のお仕事依頼をいただきますが、ちがいますので（^^;
「アタッシェケース」の開発は、本業とは関係ありませんし、あくまで趣味としてやっています。


連絡先（サポート）

バグ（プログラム上の不具合）発見やご要望など、本ソフトに関する問い合わせなどは、すべてメールで行っています。下記の宛先までお気軽にどうぞ。

その際には“必ず”お使いのアタッシェケースのバージョンと、お使いのOS（Win98 SEなのか、WinXP SP2なのか等）をお知らせください。

ただ、メール流量も多く作者多忙なため、なかなか対応できません。簡単な質問などは、ヘルプをよくお読みいただけたらと思います。返信できないときもあるかと思いますが、その辺はどうぞご理解のほどを、、、m(_ _)m

けっこう文中に「アタッシェケース」の文字もなく、簡素な質問だけ送ってくる人がいますが、ホント勘弁してください。以下のメアドはアタッシェケース専用窓口ではありません。そういうメールはフィルタリングされて、ごみ箱行きになることがあります。ご注意を。常識的なメールを書いてね。

とりあえずは、アタッシェケースに関する情報や、最新バージョンを入手する場合には、以下のサイトへアクセスしてみてください。
Vectorサイトなどへも更新をお願いしていますが、たいがいこちらよりも早く最新バージョンを上げることが多いです。

ひばら みつひろ
E-mail： |
Web site： | http://homepage2.nifty.com/hibara/software/index.htm


ＦＡＱ（よくある質問）

よく寄せられる質問などをまとめてみました。作者へバグ報告などをしていただく前に、今一度ご確認を～。

Q. | 暗号化したときのパスワードを忘れてしまいました。復号するには、どうしたら良いでしょうか？ 何か解読方法はありませんか？
A. | どうにもなりません。あきらめてください（笑）。 詳しくは、「パスワードを忘れてしまったら」のページをご覧ください。
Q. | 「ビットマップの読み込み中のエラー： ストリームからのImageListデータの読み込みに失敗しました」というメッセージが出て、アタッシェケースがまったく起動しません。
A. | OSのシステムファイルの一つ、「comctl32.dll」のバージョンが古い（version4.72以降ではない）ことが考えられます。詳しくは、「動作環境」のページをご覧ください。
Q. | 「ファイル生成中にエラーが発生しました。<******>の生成に失敗しました。復号処理を中止します。」と出て、正常に復号できません。
A. | このエラーメッセージは、<******>というファイルを作成しようとしたときに、何らかの原因により書き込めなかったときに表示されます。考えられる原因として、そのファイルが別アプリケーションにより編集中、ハードディスクまたはメディアへの書き込みができない状態などが考えられます。
Q. | 関連付け設定が有効にならないようですが・・・（暗号化ファイルがアタッシェケースアイコンになりません）。
A. | WindowsNT/2000/XPにおいて制限ユーザーなどでログオンしていると、関連付け設定が有効になりません。これはセキュリティーを考慮したWindowsの仕様です。なので、アタッシェケースの暗号化ファイルの関連付けを有効にしたい場合は、一度管理者権限でアタッシェケースを起動する必要があります（※起動時に関連付け設定を行っています）。ちなみに、Win95の一部で関連付けが有効になりません。Win95はサポート外とさせていただいておりますので、これについては仕様とさせてください。
Q. | 前のバージョンで自己実行形式で出力したのですが、復号できずにエラーが発生してしまいます。ファイルを戻せませんが、どうしたらいいですか？
A. | それは以前のバージョンにあったアタッシェケースのバグが原因です。暗号化ファイル（中身自体）は壊れていないのですが、復号化するプログラムに問題がありました。その場合は、最新のアタッシェケースに、戻せなくなった自己実行形式ファイル（*.exe）をドロップして、直接復号化すれば戻すことができます。
Q. | アタッシェケースで出力した自己実行形式（*.exe）ファイルを不特定多数の人へ配布したいのですが、作者に連絡を取る必要はありますか？
A. | ありません。 アタッシェケースが出力するファイルについては、通常の*.atcファイルも含め、自由に行ってもらってかまいません。 ただし、本体のAtchCase.exeを含むアーカイブや、インストーラを不特定多数の人たちが参照できる場所へ転載する際には、ご一報いただけると幸いです。（→詳しくは「転載・再配布」のページをご覧ください。）
Q. | 商用利用したいのですが、問題ないでしょうか？
A. | アタッシェケースの「使用」についての制限はありません。会社内で組織的に使う、何らかのプロジェクト運営上で使う等は問題ありません。「免責」 をよくお読みいただき、ご自由にお使いください。特に作者への連絡は不要です（いただければうれしいですが・・・（^^;））。また、アタッシュケースが出力した暗号化したファイルや実行形式ファイル自体（生成データ、それ自体ということです）を販売したり、製品にバンドルするなども問題ありません。 ただし、無断でアタッシェケース「本体そのもの」を販売したり（パッケージ販売とか）、別ソフトに組み込む、別製品へバンドルする、不特定多数へ配布することに対して対価を求めるなどの行為はおやめください。そういったことに関しては作者までご相談ください。（→詳しくは「使用条件・免責」）
Q. | 復号化処理中に「zlibからエラーを返されました！ エラー番号：* 」といったメッセージが表示されて中止しました。これは何？
A. | 圧縮処理で使っているライブラリからエラーを返されたようです。 考えられる原因としては、メディアへのコピー途中で暗号化ファイルが壊れたか、暗号処理中に対象ファイルを別アプリケーションなどで編集を行っていると壊れたデータを作る可能性があります。 ただ、そのようなことをしていない、何度やっても失敗するなどの「再現性」がある場合には、作者までご報告いただけたらと思います。できれば該当ファイルなどを作者まで添付してメールしていただけると原因究明に役立ちます。ただ、暗号化ファイルの方を送られる場合は、パスワード付きでないと作者も解読不能ですのでお忘れなく（^^; なお、エラーメッセージは出ても、きちんとファイルが復号されている場合もあります。 これは、ファイルは正常なのに、zlibライブラリがごくまれにCRCチェックエラーと判定してしまうことから起きるようです。なぜそんなことが起きるのか、現在調査中ですが、ファイルは問題なく復号されていることもありますので、作者へ問い合わせる前に確認してみてください。
Q. | パスワードファイルに使用されている、SHA-1の脆弱性を指摘する記事を読みましたが、アタッシェケースでは大丈夫でしょうか？
A. | 現時点では、問題ないと判断しています。詳しくは、「SHA-1について」のページをご覧ください。
Q. | 保存設定の「暗号化ファイルのタイムスタンプを元ファイルに合わせる」にチェックが入った状態で、フォルダを暗号化したのにタイムスタンプが合わないのですが・・・。
A. | Win95/98系のOSでアタッシェケースをお使いではないでしょうか？ これらのOSではフォルダのタイムスタンプを取得して、暗号化ファイルに設定することはできません。生成した日時に、タイムスタンプは設定されます。 ※なお、ファイルである場合や、NT/2000/XP以降のOSでのご使用なら問題なく設定されます。
Q. | 暗号化ファイルと、通常のファイル（またはフォルダ）を混ぜ、まとめてアタッシェケースへドラッグ＆ドロップすると、暗号化処理になったり、復号化処理になったり、挙動がマチマチです。バグ？
A. | 仕様です。 基本的にドラッグ＆ドロップされるとき、ファイルの１番目（渡す元のアプリケーションによってちがいます）が、暗号化ファイルか、ふつうのファイル（フォルダ）かどうかを判定して処理移行しています。 なので、まぜまぜしてドロップするのはやめましょう（^^;）。この処理を正常に対応しようとすると、プログラム的にも、使用的もややこしくなりませんか？ 同じフォルダの中で、一度にファイルが暗号化されたり、復号化されたりするんですよ？（笑）
Q. | サイズの小さいファイルを暗号化したら、逆にサイズが増えました。どうしてですか？ 実はバグでしょ、これ。
A. | これまた仕様です。 暗号化する際に、アタッシェケースがファイルとは別にヘッダ情報を付加するため（復号化するときの情報として記録してます）、ファイルのサイズがあまりに小さいと、逆に増えたりすることがあります。
Q. | 3.99GBまで暗号化したらエラーが出て処理が中止しました。バグですか？
A. | またまた仕様です。しかもWindowsの仕様です。 詳しくは「制限」のページで解説しています。参照ください。
Q. | 2TB（2000GB)を超えるファイルを暗号化しようとしたら失敗しました。バグだよこりゃ。
A. | 仕様ですってば。たとえNTFSにしても、１ファイル2TBの制限がありますので、同様にエラーを返して止まるはずです（作者もやったことありません）。余計なお世話かもしれませんが、秘密データ多すぎです（笑）。


改版履歴

  • ver.2.65 2009/04/08
    • コマンドラインオプションに、「list」オプションを新規追加。別のテキストファイルで指定することで、処理するファイルをまとめて指定できるようにした。
    • コマンドラインオプションから、存在しない「常に同じ場所へ暗号化・復号ファイルを保存する」パスを渡すと、そのオプションが無効になっていたのを、きちんとエラーメッセージを出すように改良。
    • 基本設定の「複数起動しない」をチェック、かつ「デスクトップで最前面 にウィンドウを表示する」がチェックしていない状態で、ファイルをアタッシェケースアイコンへドラッグ＆ドロップしても各処理に移行しなかった不具合に対処。
    • 暗号化ファイルを作ろうとしている保存先を削除しようとした場合に、エラーを出して削除処理を中止するよう改良。
    • これから作成する暗号化ファイル自身を暗号化しようとした場合に、明示的にエラーを出すように改良（今までは理由も表示されず、ただエラーとなっていた）。
  • ver.2.64 2009/03/01
    • Windows VistaでもATCファイルの関連付けを管理者権限で実行できるようにプログラムを分離して、それを本体から別途呼ぶように改良した。
    • ファイル名にUnicode文字を含むファイルを「複数で」暗号化しようとしたとき、警告もなくそのファイルだけ暗号化処理されないことがあった不具合に対処。
    • 「複数ファイルは１つの暗号化ファイルにまとめる」オプションのとき、コマンドラインオプションなどから、異なる親フォルダのファイル群を暗号化しようとすると、正常に格納されないことがあった不具合に対処。
    • パスワードを記憶するオプションで、パスワード文字列によっては、まれに暗号化・復号パスワードが記憶されないことがあった不具合に対処。
    • ヘルプファイルの「関連付け設定」などに関する記述が一部古いままになっていたので修正した。
    • Windows Vistaにおいて、アクセス許可のないフォルダのファイルを暗号化しようとすると、正常なエラーメッセージが出ずに、強制終了してしまっていた不具合に対処。
    • XP, Vistaなどの64bit OSにおいて、出力した実行形式の暗号化ファイルが正常に復号できなかった不具合に対処。
  • ver.2.63 2008/10/25
    • 関連付け設定を起動時毎回チェックするのではなく、インストーラを使ってインストールしたときのみ一回実行するようにした。
    • それに伴い「動作設定」「システム」の関連付け設定をチェックボックスからボタンUIに変更。
    • Vistaの場合のみ、ファイルアイコンの変更や関連付けに関する機能すべてをインストーラで行うようにした（アタッシェケース本体からは管理者権限があっても関連付けできません）。
    • 「動作設定」「ファイルアイコンの変更」で指定した関連付けアイコンが正しく表示されていなかった不具合に対処。
    • 動作設定「基本」のパスワードを記憶する欄に、ファイルをドラッグ＆ドロップしても、SHA-1ハッシュ値を入力できていなかった不具合を修正。
    • IISサーバから実行した時にプロセスが残るとの報告があったため、自動終了する際に統一してApplication->Terminate();を呼ぶようにした（一部変な終了をしている箇所があったため）。
    • 暗号化ファイルを実行形式で出力する際に、必ず「4GB超え」の警告メッセージが出ていた不具合を修正。
    • 設定した暗号化ファイルの保存先フォルダ自体を暗号化すると、削除設定などしていた場合、予期せず削除してしまうことがあったので、事前に警告を出すようにした。
    • 「複数ファイルは一つの暗号化ファイルにまとめる」オプションを選択した状態で、コマンドラインからディレクトリの異なるファイルを複数まとめて暗号化すると、復号時にファイル生成に失敗するという不具合に対処。
    • 遅ればせながらVista用のより大きなアイコン（48x48）表示に対応した。
  • ver.2.62 2008/02/26
    • 「基本設定」に「複数起動しない」オプションを追加して、アタッシェケースを複数起動できるように改良。
    • Windows Vista上で、メニューなどに使われる半角カナ文字が、一部環境で文字化けして表示されてしまうことがあったため、アタッシェケースで使われる半角文字列はすべて全角に変更。
    • Windows VistaでAero表示にしている際、Altキーを押すことで動作設定などのメニューが消えてしまう不具合に対処。
    • U3ドライブから起動したときには、ファイルの関連付け設定を行わないようにした（動作設定からは一応可能です）。
    • 管理者権限がないなど、ATCファイルの関連付けに失敗した場合は、動作設定の関連付け設定のチェックを外すように改良。
  • ver.2.61 2008/02/07
    • 100KB 以下のファイルを暗号化すると、暗号化ファイルがすべて100KB になってしまう不具合を修正。
      ※前のバージョンで100KBファイルを作ってしまったとしても、復号上は問題ありません。
  • ver.2.60 2008/02/06
    • 処理中のメモリバッファのサイズを大きくして、暗号/復号化の処理速度を向上させた（ただし処理するファイルサイズ、環境に依存します）。
    • 同様に完全削除処理の速度も向上。
    • Vita対応の影響で、Win95/98においてのみコモンダイアログを表示する際、しばしば強制終了していた致命的不具合に対処。
    • INIファイルオプションで、カレントディレクトリ以外にも、旧バージョンでできたアタッシェケース本体のあるディレクトリから読み出すようにした。
  • ver.2.58 2008/01/17
    • 処理によってはプログレスバーの更新が行われなかった現象に対処。
    • 復号後にファイルを開くオプションを設定しているとき、4つ以下のファイルを復号しても関連付けソフトで開かなかった不具合に対処。
    • Windows98でヘルプファイル（.chm）を開こうとすると、アプリケーションが強制終了してしまう不具合に対処。
    • U3スマートドライブでヘルプファイルが開かなかった不具合を修正（ヘルプファイル自体が壊れていたため、正常なものに差し替えた）。
  • ver.2.57 2007/10/13
    • U3スマートドライブにインストールされたアタッシェケースからヘルプファルが開けなかった不具合に対処。
    • 動作設定パネルのコモンダイアログ表示が前面に来なかった不具合への対処（前のバージョンアップの影響です・・・すみません（^^;）
    • 暗号化の際に「複数ファイルの処理」で一つにまとめるオプションを選択し、かつ「自動で暗号化ファイル名を付加する」設定にチェックを入れていても、ファイル名を問い合わせる保存ダイアログが出ていた不具合に対処。
    • 復号後のファイルが複数あったときに「復号化したファイルを関連付けられたソフトで開く」にチェックしていても最後に処理された１ファイルのみしか開かなかった不具合に対処。
    • 複数ファイルを5つ以上開く場合に、警告メッセージを表示しユーザーに選択させるように改良。
    • 「複数ファイルの処理」の設定によっては「フォルダの場合、復号後に開く」設定を行っていても開かないことがあった不具合に対処。
    • 「同名ファイルがある場合に上書きの確認をする」ときのダイアログに「すべて上書き」ボタンを追加した。
  • ver.2.56 2007/09/30
    • Vista対応の影響で、メインウィンドウが最前面にあり、かつ復号時に同名ファイルがあり、上書き確認のメッセージボックスが表示されたときにメインウィンドウの後ろに隠れてしまう不具合に対処。
    • 同様にファイルをドラッグ＆ドロップしたときにメインウィンドウが前面に来なくなっていた問題に対処。
    • ファイルを開く等のコモンダイアログ表示の際の処理を改良。
  • ver.2.55 2007/09/15
    • 内部で使用している圧縮ライブラリ(zlib）にセキュリティー攻撃の問題と、展開などの処理にバグがあったため、バージョンを最新のver.1.23に更新した。
    • ヘルプファイルを.hlp→.chm形式としてWindows Vistaでも表示できるようにした。それに伴いヘルプ内容を見直し、一部改訂した。
    • Windows Vistaにおけるタスクバー関係のアニメーションやプレビュー表示に一応対応。ただし作者がVistaを持っていないので、未確認（^^;
    • 遅ればせながらビジュアルスタイルではなかった箇所（動作設定パネル等）をすべて対応させた。
    • U3スマートドライブにインストールしようとするとエラーが発生していた不具合に対処。
    • 起動時に読み込むINIファイルオプションをアタッシェケース本体がある場所から、カレントディレクトリに変更。
    • 保存設定の「自動で暗号化ファイル名を付加する」設定に、ファイル名先頭/ファイル名末尾文字列オプションの追加。
  • ver.2.54 2006/10/08
    • U3スマートドライブへのインストールに対応。
    • ルートドライブを暗号化したとき、元ファイルの自動削除設定にしていると、ドライブのすべての内容が消えてしまっていたため、そもそもルートドライブは丸ごと暗号化できないような仕様に変更した。
    • 暗号化されたフォルダを別名で復号化しようとした場合に、正常に新規作成して復号できていなかったバグを修正。
  • ver.2.53 2006/07/09
    • 基本設定に「記憶パスワードで確認なく実行する」オプションを追加。
    • アタッシェケースをバージョンアップして起動した際に、インストール先が変わると、ATCファイルの関連付け設定が切れてしまっていたバグを修正（更新するように修正した）。
    • 「複数ファイルは一つの暗号化ファイルにまとめる」オプションで暗号化したファイルを復号すると、まとめた親フォルダのタイムスタンプに不正な値が入ってしまうバグを修正。
  • ver.2.52 2006/06/09
    • Win95/98系で暗号化したときに不正なタイムスタンプが入ると、NT/2000/XPの復号時にエラーが出て復号できなかったバグに再度仮対処（^^;
      （ちょっとどうしても予期しない値が入ることがあり、今回は例外処理で対応することにしました。）
  • ver.2.51 2006/05/24
    • 実行形式ファイルで復号しようとフォルダを選択した場合、既にあるフォルダであっても、「新しく作成して復号しますか？」と問い合わせてしまっていたバグを修正。
    • 実行形式ファイル出力時に4GBを超えても警告メッセージを表示しないコマンドラインオプションを追加。
    • 暗号/復号処理時に無駄な処理を行っていた箇所がいくつかあったので修正、最適化した。
  • ver.2.50 2006/04/22
    • 「システム」設定の関連付けファイルアイコンの登録ダイアログで、ファイルの種類表示がおかしなことになっていたバグを修正。
    • 実行形式出力ファイルで復号先の指定フォルダがない場合、フォルダを新しく作成して復号するか問い合わせるように改良。
    • Win95/98系で暗号化したときに不正なタイムスタンプが入ると、復号時にエラーが出て復号できなかったバグにとりあえず対処。（この場合、タイムスタンプは復号された日時となります）
    • ファイル名にUnicode文字が含まれる場合、そのファイル名をエラー表示して終了するようにした（Win95/98系で復号することも考え、Unicode文字があるファイル名では暗号化できない仕様としました）。
    • 同名ファイルがあった場合に、上書きする他に「別名保存」も選べるように改良。
  • ver.2.49 2005/10/10
    • マルチモニタの環境で実行形式ファイルを起動したとき、モニタの境界をまたいで、デスクトップ中央に表示されていたのをPrimaryモニタ中央に表示するようにした。
    • 実行形式での復号中は、フォルダパス選択は無効にしておくように改良。
    • 実行形式で保存先フォルダパスを直接入力しても、正しくその場所へ復号できなかったバグを修正。
    • 暗号化/復号化パスワード記憶を設定している状態で、ウィンドウメニューからファイルを開いて処理を実行しようとすると、改めてパスワードを聞かれてしまっていたバグを修正。
  • ver.2.48 2005/09/11
    • 一部のメーラー（Outlookなど）に添付されてきた暗号化ファイルを直接関連付け起動することができなくなっていた現象に対処。
    • すでにアタッシェケースが起動している状態で、コマンドラインから起動すると、引数を名前としたゴミファイルを生成してしまっていたバグを修正。
  • ver.2.47 2005/09/08
    • 大きいファイルを暗号化する際、ヘッダ情報書き込みのステップで止まっているように見えたのを、進捗表示を行うよう改良。
    • コンペアの後に連続して次のファイルの処理を行った際、前のプログレスバー表示が残っていたのをクリアするようにした。
    • 暗号/復号処理中のパーセント表示をアプリタイトル（タスクバーのタイトル表示）にも行うよう改良。
    • 実行形式のファイルを復号した際、ファイルが壊れていた場合のエラーメッセージ表示が、正しく表示されていなかったバグを修正。
  • ver.2.46 2005/07/17
    • アタッシェケース本体（AtchCase.exe）のある場所のiniファイルから動作設定を読み込んで起動した際に、ファイルをアタッシェケースアイコンへの直接ドラッグ＆ドロップしても暗号/復号化処理へ移行しなかったバグを修正。
  • ver.2.45 2005/07/11
    • コマンドラインオプションで「/delenc=0」としても有効になっていたバグを修正。
    • コマンドラインオプションで「暗号化ファイルの拡張子を偽装する」を明示的にOFFできるようにした（※詳しくはヘルプファイルを参照ください）。
  • ver.2.44 2005/6/20
    • 保存設定の「複数ファイルは一つの暗号化ファイルにまとめる」で暗号化したファイルで、かつ「復号するときに親フォルダを生成しない」にチェックが入っている状態で同ディレクトリ内にて復号すると、同名ファイルの上書きの確認メッセージが出ずに、そのまま上書きしてしまっていたバグを修正。
    • 同様の条件で、暗号化ファイルに同名ファイル（偽装などして拡張子も同一の場合）が格納されているとき、自身に上書きしようとして復号エラーが発生してしまう現象にも対処（エラーメッセージで通知し処理を抜けるようにした）。
  • ver.2.43 2005/5/19
    • Win95/98系でフォルダを暗号化し、WinNT/2000/XPで復号しようとすると「'0,0'は正しいタイムスタンプではない」といったエラーが発生することがあったバグを修正。
    • 実行形式ファイル内部に使わないコンペアルーチンが含まれていたので整理し削除した。
  • ver.2.42 2005/5/15
    • Win95/98系で保存設定の「暗号化ファイルのタイムスタンプを元ファイルに合わせる」にチェックを入れ、フォルダを暗号化すると、「'0,0'は正しいタイムスタンプではない」といったエラーが出てアタッシェケースが終了できなくなる致命的なバグを修正。
      ※Win95/98系でフォルダを暗号化した場合は、タイムスタンプは合わせない仕様とした。
  • ver.2.41 2005/5/14
    • 削除設定の「メインフォームにチェックボックスを表示する」 にチェックが入っていない状態だと、設定しても削除処理に行 かなかった凡バグを修正（^^;
    • 「メインフォームにチェックボックスを表示する」設定に関する記述をヘルプファイルに追加した。
  • ver.2.40 2005/5/13
    • メインフォームに処理後の「削除」を指定するチェックボックスを表示するようにした。それに伴って実行形式出力のチェックボックスも表示/非表示設定できるようにした。
    • コマンドラインオプションで「暗号/復号処理かを問い合わせる」（/askende）を指定した場合、正しく設定されないバグを修正。
    • アタッシェケースが出力した小さいサイズの実行形式ファイルを復号しようとすると、まれに復号できなかったバグを修正。
    • INIファイルで動作設定を読み込んだ際、レジストリには何も書き込まないはずが、"HKEY_CURRENT_USER\Software\Hibara"だけ書き込んでいたバグを修正。
  • ver.2.38 2005/5/10
    • 保存設定の「暗号化ファイルのタイムスタンプを元ファイルに合わせる」にチェックが入っている状態で暗号化すると、ファイルのタイムスタンプが乱れてしまうか、エラーが出て処理が止まってしまっていたバグを修正。
    • 同じく保存設定の「タイムスタンプを復号化した日時に合わせる」にチェックが入った状態で復号すると、タイムスタンプが９時間ずれた状態でファイルが生成されていたバグを修正。
    • 復号化の処理でやや非効率的な部分があったので改良した。微妙に実行速度が向上、したと思う（^^;
  • ver.2.37 2005/5/7
    • 動作設定の「常に同じ場所へ保存」に直接フォルダをドロップすることでパスを入力できるようにした。
    • 同様に動作設定の「パスワードファイル」パスへも直接ファイルをドラッグ＆ドロップすることで入力できるようにした。
    • コマンドラインなど実行引数指定して起動したとき、指定以外の動作設定をレジストリから読み込んでいなかったバグを修正。
    • 保存設定の「復号するときに親フォルダを生成しない」に、チェックが入っている状態で暗号時のコンペアを行うと、正常でもコンペアエラーが発生してしまうことがあったバグを修正。
  • ver.2.36 2005/4/27
    • アタッシェケースアイコンにファイルをドロップしたり、コンテキストメニューからファイルを送って暗号化すると、動作設定が初期化されて起動されてしまうバグを修正。
  • ver.2.35 2005/4/25
    • INIファイルから動作設定が読み込まれているときは、レジストリへの書き込みを一切行わないようにした（今までは一部アプリ情報や、ウィンドウサイズなどを書き込んでいた）。
    • ウィンドウサイズや、位置などの記録についてもINIファイルへ書き込むように仕様変更。
  • ver.2.34 2005/4/23
    • せっかく新規追加した機能の「INIファイル設定オプション」 が、まったく機能していなかった凡バグに対処（^^;
    • アタッシェケース本体（AtchCase.exe）があるフォルダを、常に保存する先として指定できる保存オプションを追加。
  • ver.2.33 2005/4/22
    • 動作設定内容を.INIファイルに書き出すオプションを追加。また実行ファイルや暗号化ファイルのある場所に、その.INIファイルを置いておくことで、一時的な動作設定としてアタッシェケースを起動できるようにした。
    • 「復号するときに親フォルダを生成しない」保存オプションを追加。
    • 内部で使用しているzlib圧縮ライブラリをver.1.22に更新。
    • 極めて特殊な状態の暗号化ファイルを復号すると、ファイル末尾を壊してしまう致命的なバグを修正。
    • 拡張子偽装設定を行ってから、暗号化や復号化を行った際に、同名ファイルパスへの上書きを許し（hoge.jp -> hoge.jpgなど）、ファイルを壊していた不具合を修正。エラーを出して処理を中止するようにした。
    • Win95/Win98で暗号化したファイルを復号したときに、正しく元の作成日時が設定されていなかった不具合を修正。
    • 管理者権限でインストーラを起動しセットアップを行っても、スタートメニューの共通グループにショートカットが作成されていなかった不具合を修正。
  • ver.2.32 2005/3/15
    • コマンドラインオプションで、暗号化/復号化パスワードを設定せずに起動してファイルをドラッグ＆ドロップすると、勝手にパスワードとして "0" か "1" を入力され、暗号化されてしまう致命的なバグを修正。
  • ver.2.31 2005/3/14
    • コマンドラインオプションで、完全削除を指定してもきちんと設定され起動していなかったバグを修正。またヘルプファイルの指定の仕方も間違っていたので、そちらも併せて修正した。完全削除の指定は、"/del=2", "/delenc=2"に変更した。
    • 英語版ファイル内部のバージョンナンバーが古いままだったのを修正した。
  • ver.2.30 2005/3/13
    • 現在の動作設定をバッチファイルなどのファイルへ出力するシステムオプションを追加。
    • また、一時設定で起動している内容をメインの動作設定へ置き換え、保存するシステムオプションも追加。
    • コマンドラインオプションに「パスワードにファイルの指定を許可する」（"/pf="）を追加。
    • コマンドラインオプションに「常に同じ場所へファイルを復号化する」（"/dsaveto="）を追加。
    • コマンドラインオプションで"/del=3"と指定して起動しても、完全削除が行われていなかったバグを修正。
    • ヘルプファイルにある「起動時のコマンドオプション」で、「暗号化ファイルの拡張子を偽装する」の指定の記述が誤っていたのを修正。
  • ver.2.28 2005/3/11
    • 実行可能形式のインターフェースを改良し、内部処理なども少しだけリファイン。
    • 少し前に発表された、SHA-1の脆弱性についての記述をヘルプファイルに追加（作者として現時点では問題なしと判断）。
  • ver.2.27 2005/2/18
    • 暗号化/復号化パスワードの記憶で、文字列を全く入力せずにキャンセルで抜けた場合に、意図せず「パスワード無し」の指定になっていたのを抜けられないように改良。
  • ver.2.26 2005/2/16
    • システム設定の「ファイルアイコンの設定」で、ユーザー指定アイコンを登録してもアタッシェケース終了後に登録が解消されてしまうバグを修正。
  • ver.2.25 2005/2/15
    • 基本設定のパスワード記憶の欄にパスワードファイルをドラッグ＆ドロップした際、ファイルの種類によっては記憶できずにアタッシェケース自体が落ちていた致命的なバグを修正。
    • 同じくパスワード記憶のオプション指定がなく、ファイルをドラッグ＆ドロップした際、パスワード入力ダイアログが出てしまっていたバグを修正。
  • ver.2.24 2005/2/13
    • Win98系の環境で、かつ保存設定の「自動で暗号化ファイル名を付加する」にチェックが入っている状態だと、不正なファイルパスが生成されてしまい暗号化できなかったバグを修正。
  • ver.2.23 2005/2/12
    • 処理開始時に、暗号/復号処理かを問い合わせるオプションを基本設定に追加。また明示的に暗号/復号を指定できるコマンドオプションも追加。
    • 保存設定にある暗号化/復号化パスワードの記憶メニュー部分に、ファイルを直接ドラッグ＆ドロップすることで、そのファイルのSHA-1ハッシュ値をパスワードとして登録できるようにした。
    • 自己解凍インストーラで、任意のイントール先フォルダを指定できなくなっていた（デフォルト"Program Files"固定になっていた）不具合を修正。
    • 英語版で一部、日本語が使われている部分があったので修正。
  • ver.2.22 2005/2/2
    • 複数ファイルを処理するときのオプションを追加。フォルダ内にある複数ファイルを個別に暗号/復号できるようにした。
  • ver.2.21 2005/1/24
    • Explorerやデスクトップなどで、暗号化ファイル(*.atc)の上でコンテキストメニュー（右クリック等）を表示した際に、「開く」ではなく「復号化」と表示するように改良。
    • 復号時にディスクの空き容量が足りずにエラーとなった場合、容量不足である旨のメッセージが出るように改良。
    • 前回対処したはずだった、Win95/98上で復号する際にタイムスタンプ設定がうまくいかない不具合に、今度こそ対処（^^;
    • 特殊フォルダ、特定のボリュームラベルのドライブを、常に保存する先として指定できるオプションを追加。
    • それに伴って指定された保存先が見つからない場合は、エラーメッセージを出して処理を中止するように仕様変更。
  • ver.2.20 2004/11/01
    • 「指定のパスワードファイルを自動チェックする」にチェックが入っている状態で、パスワードを間違えて復号が失敗した後、正しいパスワードを入力しても、復号に失敗していた不具合に対処。
    • またパスワードファイルを間違えて失敗した後に、正しいパスワードファイルをドラッグ＆ドロップしても復号に失敗していた不具合に対処。
    • パスワードファイルの自動チェックを、暗号時と復号時に分けて設定できるように新しく機能追加。
    • Win95/98上で復号する際に、タイムスタンプ設定がうまくいかず、正しく復号することができなかった不具合に正式対処。
  • ver.2.18 2004/10/28
    • コマンドラインオプションで、ネットワーク上にあるフォルダを指定して暗号化しようとした場合に「フォルダが見つかりません」といったメッセージが出て、暗号化できなかった不具合に対処。
  • ver.2.17 2004/10/20
    • Win95/98上で復号する際に、タイムスタンプ設定がうまくいかず、正しく復号することができなかった不具合に対して仮対処。
      ※現在、作者がWin98系での動作確認が行えない状態なので、仮に以前のタイムスタンプを設定しない復号を行う仕様に戻した（Win95/98系のみ）。
  • ver.2.16 2004/10/18
    • 復号時のパスワードを記憶した状態で、異なるパスワードの暗号化ファイルの復号に失敗すると、パスワードの再入力を促されるが、そこで正しく入力し直してもきちんと復号されなかった不具合に対処。
  • ver.2.15 2004/10/15
    • 「保存」の「複数ファイルは一つの暗号化ファイルにまとめる」オプションにチェックしている状態で、実行形式で出力しようとすると、デフォルトで".atc"の拡張子になっていた不具合を修正。
    • 英語版で「ファイルを開く」などのコモンダイアログのタイトル各所が、英語表記になっていなかったのを修正。
  • ver.2.14 2004/10/8
    • 「暗号化ファイルのタイムスタンプを元ファイルに合わせる」保存オプションを追加。
    • 復号時に、フォルダのタイムスタンプもきちんと復元されるように改良した（今までは新規作成扱いで復号された時点のタイプスタンプになっていた）。ただし、NT/2000/XP系のみ。
    • 通常削除、完全削除の際に、フォルダが「隠しファイル」「読み取り専用」属性になっていると、まれに削除できずに残ってしまっていた不具合に対処。
    • 暗号化/復号処理中は上部メニューにアクセスできないように改良。
  • ver.2.13 2004/10/3
    • 実行形式出力（*.exe）を行った際、拡張子偽装オプションを設定していると、コンペアに失敗していた不具合に対処。
    • 拡張子偽装オプションで「.exe」を指定して作成した暗号化ファイルをアタッシェケースにドラッグ＆ドロップしても、正しく復号処理に移行しなかった不具合に対処。
  • ver.2.12 2004/10/2
    • 実行形式出力（*.exe）を行った場合に、拡張子偽装オプションが機能していなかった不具合に対処。
  • ver.2.11 2004/9/29
    • WindowsXPのビジュアルスタイル以外での環境で起動すると、ウィンドウ上部メニューの表示が乱れてしまっていた不具合に対処（※前のバージョンでデザイン改良した影響です）。
    • ヘルプファイルの一部記述を修正、追加。
    • メインアイコンをちょっとだけ色調整。
  • ver.2.10 2004/9/23
    • 復号の際のパスワード入力ミスを三回まで許し、再入力を促すように改良。
    • 名前にピリオド "." が含まれているフォルダを暗号化した際に、拡張子の解釈がうまくいかず、ピリオド以下の文字列が消えて暗号化ファイルを生成していたバグを修正。
    • ヘルプファイルの「使用条件・免責」のページを追加。
    • フォームデザインを少しだけ改良。
  • ver.2.08 2004/8/13
    • 読み取り専用のファイルを暗号化して、コンペアをした場合に、エラーが発生し正常終了しない場合があったのを一応対処。
    • また、コンペア中にエラーで抜けた際、内部的にファイルがアタッシェケースによって開かれたままになっていたのを修正。
    • 元ファイルが読み取り専用になっていると、正常に削除処理が行えなかった不具合に一応対処。
    • 完全削除処理の中で、一部エラー処理がきちんと働いていなかった箇所を修正。
  • ver.2.07 2004/8/9
    • ショートカットファイルにコマンドラインオプションを指定して、ファイルをドロップした場合に、パスワードファイルのパスをうまく認識できなかった不具合に対処。
    • 動作設定パネルの挙動（パス表示を末尾に合わせる等）を少しだけ改良。
  • ver.2.06 2004/8/8
    • 「自動で暗号化ファイルを付加する」の設定が正しく機能していなかったバグを修正。
    • ヘルプファイルの「起動時のコマンドオプション」の中で、引数"autoname"の説明がまちがっていたのを修正。
    • 暗号化、復号化の後で、元ファイル/暗号化ファイルを削除するかを個別に指定できるようにした。
  • ver.2.05 2004/8/7
    • 上部メニュー「終了」から終了できなかったバグを修正。
    • 特定の状況でフォルダに入った複数の圧縮ファイル（.lzh等）をver.1で暗号化してから、ver.2で復号しようとすると、「zlibエラー:-5」が発生し戻せなかった不具合に対処。
  • ver.2.04 2004/8/4
    • ファイルサイズが小さく、ファイル末尾が特殊な状態になっていると復号できないことがあったバグを修正（※暗号化ファイルが壊れているわけでなく、復号ルーチンのバグです）。
    • 通常の暗号化ファイル（*.atc）において、パスワードファイルが機能しておらず、NULL（空文字）として入力されていたバグを修正。
    • また、旧バージョン（ver.1.**）で、パスワードファイルにより暗号化したファイルが戻せなかったバグを修正。
  • ver.2.03 2004/7/31
    • 実行形式で出力した際に、パスワードファイルを受け付けなかった不具合に対処。
    • また、実行形式ファイルに「フォルダ」をドロップした場合に、フリーズしていた不具合にも対処。
  • ver.2.02 2004/7/30
    • パスワードが入力できなくなっている問題に対処。毎度毎度お騒がせしております、はい・・・（^^;
  • ver.2.01 2004/7/29
    • 実行形式出力したファイルが復号できないバグを修正。毎度、凡バグですみません・・・（^^;
    • 復号時のときはパスワードの文字制限をかけないようにした。（Blowfishで暗号化されたファイルの場合があるのと、不要かと思われるため）
  • ver.2.00 2004/7/25
    • 暗号化アルゴリズムをBlowfishから、より強力なRijndaelへと変更した。それに伴って、初期化ベクトル（IV）を生成してから、CBCモードで暗号化するように改良。第三者による暗号化特徴からの解析をされにくくした。
    • それにより内部的なデータバージョンを上げた。今バージョンで暗号化したファイルは、以前のバージョンでは復号できなくなったので注意（※その逆は上位互換なので問題なし）。
    • パスワードファイルの先頭データからパスワードを抽出する仕様から、SHA-1のメッセージダイジェストを使う仕様に変更。
    • ファイルコンペア機能を追加。暗号化した後に、元データとコンペアすることで、正しく復号できるかどうかをチェック可能にした。
    • アタッシェケースファイルのアイコン（関連付けアイコン）を任意に変更できるようにした。
    • 動作設定のいくつか（すべてではない）をコマンドラインオプションとして指定実行できるようにした。
    • メジャーバージョンアップということで、アプリアイコン、フォームデザインを一新（単なる自己満足です♪）。
    • タイムスタンプが奇数秒のファイルを暗号化/復号した際に、偶数秒に丸められていたバグを修正。
  • ver.1.46 2004/7/25
    • 「暗号化ファイル名に拡張子を含める」と「自動で暗号化ファイル名を付加する」にチェックを入れ "<filename>" のみにすると、暗号化に失敗し、元ファイルが削除されてしまうバグを修正。
    • 前述の設定の組み合わせによっては、一部機能しないことがあったので、「自動で暗号化ファイル名を付加する」設定の優先度を上げることにした。
    • その他、細かい改良。
  • ver.1.45 2004/7/1
    • 復号時に、特定の条件が揃うと、終端の1byteに異なるデータを書き込んでしまっていたバグを修正。
    • 前バージョンで仮処置したzlibからCRCチェックエラーが返される問題について、原因がわかったので根本対処した。
  • ver.1.44 2004/6/4
    • 内部で使用しているzlibライブラリが、データによってはごくまれにCRCチェックエラーを返し（謎です・・・調査中）、復号できなかったのを、途中停止しないよう最後まで処理するようにした。
      （※データ自体は問題なく復号できるので、zlibエラーが出た場合のみ、復号完了後にエラーメッセージを出すようにした）。
    • 復号化最中にエラーが発生した際、暗号化ファイルを内部的にきちんとクローズして抜けていなかったのを修正。
  • ver.1.45 2004/7/1
    • 復号時に、特定の条件が揃うと、終端の1byteに異なるデータを書き込んでしまっていたバグを修正。
    • 前バージョンで仮処置したzlibからCRCチェックエラーが返される問題について、原因がわかったので根本対処した。
  • ver.1.44 2004/6/4
    • 内部で使用しているzlibライブラリが、データによってはごくまれにCRCチェックエラーを返し（謎です・・・調査中）、復号できなかったのを、途中停止しないよう最後まで処理するようにした。
      （※データ自体は問題なく復号できるので、zlibエラーが出た場合のみ、復号完了後にエラーメッセージを出すようにした）。
    • 復号化最中にエラーが発生した際、暗号化ファイルを内部的にきちんとクローズして抜けていなかったのを修正。
  • ver.1.43 2004/3/24
    • アイコンに複数ファイルをドラッグ＆ドロップしたときや、コンテキストメニューの「送る」へファイルを送ったときに、うまく暗号/復号処理できていなかったバグを修正（最近の改良で仕込んじゃったようです、すみません・・・）。
    • 「完全削除」のゼロ書き込み、乱数書き込みの両方が機能して おらず、サイズ0にしていただけだった凡バグを修正（こちらも最近仕込んだようです・・・）。
  • ver.1.42 2004/3/15
    • 前バージョンの修正に伴い、旧バージョンでパスワードファイルを使って暗号化したファイルが、復号できない場合があったのに対処。
  • ver.1.41 2004/3/14
    • Blowfishのパスワード長の制限が56バイトのため、予期せぬ値が入らないように修正した（今更ですがすんません…）。
      ※なので「パスワードファイル」も255バイトではなく、今後は56バイトしか入りません（^^;
  • ver.1.40 2004/3/9
    • コマンドラインオプションで、相対パスで指定されると、ファイルが見つからず、暗号化（または復号）できないことがあったバグを修正。
  • ver.1.39 2004/3/2
    • 同名ファイルへ上書きして暗号化した際に、エラーが発生し処理を抜けたときのみ、先にあった暗号化ファイルを壊してしまうことがあったのを回避するよう改善。
  • ver.1.38 2004/2/24
    • 「常に自己実行形式で出力する」オプションを基本設定に追加。
    • 圧縮が効きやすく、特定のサイズのファイルを暗号化した際、まれに誤った形で格納され、復号化した際にデータ末尾が壊れるか、切れてしまう致命的なバグを修正。
  • ver.1.37 2004/2/19
    • パスワード入力ボックスにフォーカスがあるときは、「貼り付け」などのコンテキスト（ポップアップ）メニューを表示するようにした。
    • 末尾に大量の空フォルダが連続して格納された暗号化ファイルを復号化しようとすると、インデックスエラーが出て、アタッシェケースが終了できなくなるバグを修正（※ただし、データは正常に復号化されているようでした）。
  • ver.1.36 2004/2/14
    • 自己実行形式で復号化する際、保存先を指定できるようにした。
    • 前バージョンにて制限ユーザー時のレジストリ書き込みの不具合を修正した関係で、関連付け設定が一部有効にならなくなってしまっていたバグを修正。
    • 属性が読み取り専用のファイルを復号化したとき、タイムスタンプが作成時となってしまっていたバグを修正。
    • 「キャンセル」「閉じる」ボタンの名称を各ステップでそれぞれ変更。また通常フォームでのボタンは「終了」としてみた。
  • ver.1.35 2004/2/3
    • 「保存」設定に「自動で暗号化ファイル名を付加する」機能を追加。ファイル名に日時や連番を振ったり、ランダムな文字列等で名前を自動付加できるようになった。
    • それに伴って動作設定パネルのレイアウトを少し整えた。
    • Windows2000/XPなど制限ユーザーでログオンし使用した場合に、レジストリ書き込みエラーとなり、まったく起動しなかった致命的なバグを修正。
  • ver.1.34 2003/12/27
    • 4GBを超える実行形式ファイルを生成してしまうと、Win32アプリケーションとして実行できなくなるので（Windowsの仕様）、暗号化ファイルを作成する前と、処理中4GBを超えるときに、メッセージで問い合わせるようにした。
      ※通常の*.atcファイルは問題ありません。
    • 巨大ファイルを暗号/復号/削除処理する際、長らく制御が戻らずキャンセルなどしにくかったのを改善。
    • 質問が多かったのでヘルプファイルに「制限」の項目を追加。
  • ver.1.33 2003/12/20
    • 完全削除のゼロ書き込み削除の際に、プログレスバーが描画されなかったバグを修正（なぜ今まで放置されていた？（^^;))。
    • 暗号/復号と完全削除でプログレスバーの色を替えるようにしてみた。
  • ver.1.32 2003/11/24
    • 起動時のコマンドオプションとしてパスワード（文字列のみ）を指定できるようにした。
  • ver.1.31 2003/11/23
    • 暗号化時と、復号時のパスワードを分けて記憶できるようにした。また、記憶パスワードが他のツール等で読み取られないように少しだけ工夫して管理。
    • 高度な設定で「パスワードファイルの指定許可」をチェックしてなくても「自動チェックする」にチェックがあると、勝手に自動チェックしに行っていたバグを修正。
    • 複数のファイルを暗号化する際、パスワードの自動チェック設定をしていると、一ファイルごとにパスワードファイルを読んでしまっていたのを最初の一回だけに修正。
    • 自己実行可能形式で出力した際に、バージョン情報の内容が消えていた不具合に対処（※動作的には全く支障ありません）。
  • ver.1.30 2003/11/9
    • 高度な設定としてパスワードファイル機能を新しく追加。
    • 高度な設定として拡張子偽装設定を新しく追加。
    • ネットワーク上のファイルを暗号/復号化しようとするとエラーになり、処理を実行できなかったバグを修正。
      ※但し、Win95 OSR2以前では修正されず機能しません。あしからず。
  • ver.1.25 2003/10/5
    • 暗号化ファイルに格納するファイル種類と順序によっては、zlibエラーを返し、復号データの末尾が切れるバグを修正。圧縮のききにくいファイルがデータ末尾に格納されると、まれに発生していた模様。
    • その他、自己実行可能形式出力周りの細かいバグ修正＆リファイン。
  • ver.1.24 2003/9/21
    • ファイルサイズによっては復号化できなかったバグを修正（何度もスミマセン・・・（^^;））。
    • 出力した実行可能形式ファイル（*.exe）をアタッシェケースにドロップする（または開く）ことでも復号化できるようにした。
  • ver.1.23 2003/9/13
    • 暗号化されたフォルダの中に、ファイルサイズが小さく（64バイト以下）かつそれらが複数ある状況で、一番最後にサイズの小さなファイルを復号化しようとするとzlibエラーが発生し、復号できなかったバグを修正。
    • 「暗号化ファイル名に拡張子を含める」オプションを追加。
    • 動作設定パネルの正しくなかったタブオーダーを修正。
  • ver.1.22 2003/9/8
    • Win9x系で、作成した自己実行形式ファイルを復号しようとすると「ファイルを開くことができません！‥‥」云々といったエラーが出てしまっていた凡バグに対処。今度こそ大丈夫なはず。それしてもダメダメですみません‥‥（泣）
  • ver.1.21 2003/9/7
    • Win9x系で、自己実行形式出力しようとすると、「ファイルを開くことができません！‥‥」云々といったエラーが出て、生成できていなかった凡バグに対処。
  • ver.1.20 2003/9/6
    • 自己実行形式出力に対応。アタッシェケースのない環境でも暗号化ファイルを渡して、復号できるようになった。
  • ver.1.12 2003/08/28
    • プログレスバー表示をオリジナルで描画することにした。
      （※サイズを小さくするため、自己実行形式出力への布石です。）
  • ver.1.11 2003/8/23
    • 暗号化におけるファイルリスト生成処理の最適化を行った。数の多いファイルを処理する際の処理速度が向上。
    • 復号化においるファイルリスト生成処理の最適化を行った。数の多いファイルを含む暗号化ファイルを復号する際の速度が、大幅に向上した（今までが重すぎでした（^^;））。
    • 大量のファイルを処理していると止まっているかのように見えていたので、処理過程を表示するように改良。
    • 他アプリで使用中のファイルを含むフォルダを無理やり暗号化した際に、予期せぬエラーを引き起こしていたのを改良。きちんとエラー処理して抜けるよう対策を施した。
    • Windows95での動作保証とサポートを終了した（※詳細は「動作環境」の項目を参照ください）。
  • ver.1.10 2003/8/4
    • 削除設定を「ごみ箱への削除」にしていた際に、処理したファイルやフォルダがすぐに表示されないことがあったため、念のため毎回フォルダ内の表示更新を行うようにした。
    • ごみ箱への削除に失敗した場合、エラーメッセージを表示するようにした。
  • ver.1.091 2003/7/17
    • 誤って関連付け設定を切ってしまい、機能していなかったバグを修正（^^;
  • ver.1.09 2003/7/16
    • 国際化対応を行った。とりあえず「英語（U.S）」だけにローカライズを行った。（※将来的には多言語に対応可能）
    • メインウィンドウの最大化も含めたリサイズを可能にした。
    • 完全削除を行った際のプログレスバー表示で、回数分まとめて表示していたのを分かりやすく回数ごとの表示に変更。
    • パスワード入力をまちがえたときにエラーが出て落ちていた致命的なバグを修正（巨大ファイル処理改良時の影響です）。
    • 復号化で特定な操作を行うことでファイルが内部的に開いたままとなり、正常に復号処理が行えないことがあったバグを修正。
    • メインウィンドウの「記憶する」チェックボックスの挙動を少し改良。
  • ver.1.08 2003/6/23
    • 暗号/復号化する際、まれに前のメッセージがメインウィンドウ上に残ったり、正しく表示されていなかったバグを修正。
    • 4GBを越える巨大ファイルを復号化する際、ファイルサイズが取得できず、復号化できないことがあったバグを修正。（※Win2000/XPで、かつファイルシステムがNTFSの場合のみ）
    • 同様に4GBを越える巨大ファイルを処理する際プログレスバーおよびパーセンテージ表示が乱れてしまっていたバグを修正。（※Win2000/XPで、かつファイルシステムがNTFSの場合のみ）
    • メインウィンドウのパスワードを「記憶する」チェックボックスが、有効になっていなかったバグを修正（いつの間に？）。
    • 以前修正したが、Explorerなどからアタッシェケースファイル（*.atc）を複数開いた際に、まれに一部だけファイルが復号化されずに残ってしまうのに対処。けっこうシビアなタイミングで処理しているので、完全には対処できないかも。
    • 常に同じ場所へファイルを復号化する設定を行っている際に、元ファイルのある方のディスクの空き容量チェックを行ってしまっていたバグを修正。
    • 遅ればせながらWindowsXPのビジュアルスタイルに対応（^^;
  • ver.1.07 2003/6/8
    • 関連付け設定と、削除設定のゼロ書き込み設定が正常に記憶されないことがあり、正しく設定が反映されないバグを修正。
    • 「複数ファイルは一つの暗号化ファイルにまとめる」で、完全削除などを行ったとき正常に削除できず、場合によっては不正な処理になっていた致命的バグを修正。
    • 完全削除中のプログレスバーが正しく表示されていなかったバグを修正。
    • その他、細かい内部的な修正など。
  • ver.1.06 2003/6/4
    • 動作設定の「保存設定」→「複数ファイルは一つの暗号化ファイルにまとめる」をチェックして、元ファイルのある場所以外へ暗号化ファイルを作成すると、復号化できなくなるという致命的なバグを修正（※十分にテストしたのですが・・・面目ありません（^^;））。
    • 常に同じ場所へファイルを復号化するオプションを追加。
  • ver.1.05 2003/6/3
    • 「常に同じフォルダへ暗号化ファイルを保存する」設定で、フォルダ選択ダイアログを出したとき、メインウィンドウが前面に出てきて邪魔していたバグを修正。
    • 単体ファイルなど、復号化した際、暗号化する前のタイムスタンプに正しく設定できないことがあったバグを修正。
    • Windows9x系で、かつ一部の環境によっては、うまくatcファイルの関連付け設定が行われないというバグの原因らしき箇所を修正してみた（※当方の環境では確認不可）。
    • 同じくWindows9x系でアイコンへファイルをドラッグ＆ドロップしたり、関連付け起動した際に短いファイル名（MS-DOS形式）に変換されてしまい、正常に暗号/復号化できなくなっていた大バグを修正。
    • 暗号/復号化の最中にキャンセルした際、一部ファイルを閉じずに中止していたため、連続して再処理を行うとエラーが出て処理が行えないバグを修正。
    • 復号化の際のプログレスバーの表示が不正確だったバグを修正。
    • 暗号化ファイルと、その元ファイルを一緒にドラッグ＆ドロップすると予期せぬエラーが出ていたバグを修正（※きちんとエラー処理して抜けるようにした）。
    • Explorerなどで複数の暗号化ファイル（*.atc）を選択し実行したとき、一つのファイルしか復号化されなかった仕様を改良（※バグではなくWindowsの仕様だったようです）。
    • この仕様改良に伴い、パスワード入力中のウィンドウキャプションに処理中のファイル名が表示されていた仕様を削除。
    • 複数ファイルを処理する際、一つの暗号化ファイルにまとめるオプションを追加。
    • 復号化したファイルを関連付けされたアプリケーションで自動オープンするオプションを追加。
    • 復号化したファイルのタイムスタンプを作成時に合わせるオプションを追加。
    • 削除設定でWindowsの「ごみ箱」への移動オプションを追加。
    • これらのオプション追加に伴い、設定パネル項目の整理を行った（※順番やタブ分けが変わっただけで以前の設定はそのまま受け継がれます）。
    • その他、細かい修正＆改良。
  • ver.1.04 2003/5/10
    • パスワードに「aaaaaa」や「abcabc」など、繰り返しで、かつ偶数文字で設定すると、繰り返し文字単位（「a」や「abc」）の入力だけで、復号化できてしまうバグを修正。
      ※それにより、内部的なデータバージョンが上がり、今バージョンのアタッシェケースで暗号化されたファイルは、旧バージョンで復号化できなくなりました。ご注意ください。
    • この修正に伴い、パスワード入力において「空白（無記入）」にしても暗号／復号化できるような仕様に改良。
      ※ただし、空白のパスワードは「記憶」できない仕様のままにした（セキュリティーを考慮して）。
    • 複数のファイル／フォルダをドラッグ＆ドロップして暗号化すると、ドロップしたすべてのファイルを１ファイルに格納していってしまう大バグ（凡バグとも言う（^^;ゝ）を修正。
    • アタッシェケースを起動中に、関連付けられた暗号化ファイルをダブルクリック、またはアイコンへファイルをドラッグ＆ドロップしても処理移行しなかったのを修正。
    • 「処理後、アタッシェケースを終了する」にチェックを入れ、暗号・復号化処理をすると、「無効/非表示ウィンドウにはフォーカスを設定できません」といったエラーが出ていたバグを修正。
    • 同様の不具合で「動作設定」のパスワード設定入力ボックスで、無記入のままEnterキーを押すと、同じエラーメッセージが出ていたバグを修正。
    • パスワード入力ボックスで、EnterキーやEscキーを押すたびごとにBeep音が鳴っていたのを消去するようにした。
    • 処理中、制御が戻る間隔を少しだけ短くした（プログレスバーの伸び方などが少しだけ滑らかになった）。
    • メニューの「暗号／復号化するファイルを開く」をそれぞれ、「暗号化するファイルを開く」と「復号化するファイル」に分けた。
  • ver.1.03 2003/5/2
    • 一部の内部アイコンが壊れていたため、関連付けても鍵マークアイコンが表示されなかったバグを修正。
    • 処理後、キャンセルボタンにフォーカスが移るように改良。
  • ver.1.02 2003/5/1
    • 動作設定ウィンドウでタブオーダーがおかしくなっていた部分を修正。
    • 環境によってはアタッシェケースのウィンドウが意図しない形のサイズになっていたバグを修正。
    • 処理後、いったんキャンセルしないとファイルのドラッグ＆ドロップを受けつけなかったのを、処理が完了していれば連続して受けつけることができるように改良。
    • 自動終了設定をしていれば、ユーザーキャンセルやエラーが発生した場合であっても、そのまま自動終了していたが、その場合のみしないように改良。
    • "*"文字で隠さず、パスワードを確認しながら入力できる設定を追加。
    • 暗号/復号処理中のファイル名を、ウィンドウキャプションに表示するようにした。
  • ver.1.01 2003/4/19
    • 暗号/復号化ボタンを押して、ダイアログからファイルを選択しても、暗号/復号処理できなくなっていたバグを修正。
  • ver.1.00 2003/3/31
    • 正式公開版としてリリース。
    • 動作設定パネルのパスワード入力の際に、無記入で記憶できてしまうバグを修正（これで暗号化すると落ちてました（^^;））。
    • 暗号化ファイルに含めるファイルリストに無駄なタブ文字が含まれていたので省いてちょっとだけサイズを小さくした。
    • ルートに置いてある暗号ファイルを復号化した際、うまくExplorerへ渡せず、「復号後に開く」の設定が有効にならなかったバグを修正。
  • ver.0.07β 2003/3/24
    • 指定の保存先が削除されるなど、無くなっていた場合に、正常に暗号化ファイルを作れなかったバグを修正。
    • ログを残すなど、すべてのデバッグ機能を外し、正式公開へ向けての最終デバッグ開始。
  • ver.0.06β 2003/3/16
    • ファイルが一つも入っていない状態で、深い階層にしたフォルダを暗号化すると、正常に動作しなかったバグを修正。
    • 関連付け設定を切っても、起動時に関連付けられてしまうので、オプション設定を行った場合に限り、それをキャンセルするようにした。
    • 全角で127文字を超えるようにIME変換して一気にパスワード入力すると、エラーメッセージが超えた文字数分だけ出てしまうバグを修正（^^;ゝ
    • ディスクの空き容量をチェックして、いっぱいになったときは処理をはねるようにした（エラーを出してキャンセルされるようにした）。
    • それに伴って4GBくらいまでのファイルしか扱えなかったのを、それ以上の巨大ファイル処理にも対応（そんなの暗号化するかどうかはともかくとして）。
    • 暗号／復号化した際に、同名ファイル（またはフォルダ）があった場合、上書き確認のメッセージがいつの間にか出なくなっていたバグを修正（^^;
  • ver.0.05β 2003/3/10
    • 素っ気ないデザインからグラフィカルなデザインに変更（笑）
    • テンポラリファイルを使わずにすべてメモリ上で、圧縮→暗号の処理（または復号→解凍処理）を行うようにした。そのおかげでセキュリティーも向上。
    • 解凍した際に、元ファイルの属性やタイムスタンプを記憶していなかったのを、きちんと再現できるようにした。
    • 関連付け起動して復号化した際に「フォルダを開く」設定が利いていなかった不具合を修正。
    • メインウィンドウをデスクトップで常に最前面にする機能オプションを追加した。
    • 「送る」フォルダへショートカットを作るオプションを追加
    • ヘッダが壊れている状態で、暗号化ファイルを読み込ませると、暗号化処理に移行してしまうのをエラーが出るように改良。
    • エラーが発生したとき、まれにメッセージ表記が重なって乱れてしまう不具合を修正。
    • ファイルリストの持ち方などに変更を加えたため、内部的なデータバージョンを上げた。（1.0.1→1.0.2）
  • ver.0.04β 2003/1/7
    • 動作設定パネルの「関連付け設定の解除」のボタンが有効になっていなかった凡バグを修正。
    • アーカイバDLLを使った圧縮機能を廃し、フリーライブラリの zlib圧縮を使って、独自処理するように大改造。
    • それにより、環境によってDLLがないなどの複雑なエラー処理を行う必要がなくなり、関連バグもなくなった。
    • また、圧縮方法の変更に伴いATCファイルデータ構造を変更し、内部的なデータバージョンを上げた。（1.0.0→1.0.1）
    • オプションで、常に指定の場所（フォルダ）へ暗号化ファイルを生成できるようにした。
    • 完全削除の初期設定を、乱数は0回、NULL値は1回という設定にした（あまりにも処理に時間がかかるため）。
      ※もちろん後からユーザーが変更できます。
    • 復号化した際に、フォルダだけではなく、１ファイルのときも 同名ファイルがあれば、上書きの確認を行うようにした。
  • ver.0.03β 2002/12/26
    • 「閉じる」ボタンを追加。
    • 処理実行中以外は「中止」ボタンを無効にしておくようにした。
    • アイコンへ直接ファイルをドラッグ＆ドロップする処理が利いていなかったバグを修正。
    • 暗号／復号化処理後に、完了メッセージを表示するようにした。
    • フォルダ内に１つもファイルがない場合、ただ処理中止をしていたのを、きちんとエラーメッセージ表示するようにした。
    • 復号化した先に同名ファイルがあると、連番を付加して上書きしてしまうバグを修正。
    • 設定したアーカイブの種類によっては、復号化したときに「圧縮DLLがありません」というメッセージが出て、処理が行えなかったバグを修正。
  • ver.0.02β 2002/12/18
    • 処理途中で中止できるようにした。
    • また処理中、強引に終了させても正常に終了するように改良。
    • 同名のアーカイバファイルがあると、正常に復号化できなかったバグを修正。
    • 同様に、同名フォルダがある場合に、無条件で上書きしていた処理をユーザーに問い合わせするようにした。
    • ヘルプファイルを大幅に改編。
  • ver.0.01β 2002/11/13
    • 非公開でベータテスト版リリース


セキュリティーを「コスト」で考える

作者はその筋の専門家ではありませんが、数多くの暗号化ソフトを購入したり、試したりしている経験から（こういうの大好きなんです（^^)）、セキュリティーを「コスト」で考えるとわかりやすいかな、と思っています。

「この秘密を守るために、これだけのコストをかける必要があるか？」

といった具合にです。

テキストファイルのあなたの「秘密日記」を、世界中のクラッカーが盗み見てみたいと思うでしょうか？（笑）　家族から見られたくないというレベルなら、数千円で売られている暗号ソフトを導入するまでもなく、ファイル名を適当なやつにしておくか、拡張子（.txt）を別の .jpg などに偽装しておけば事足りますし、それ以上のコストをかけるのは無駄かなあと思います。

なので、以下のことを天秤にかけるといいかなと。
けっこう当たり前のことですが、よく見失いがちになるので。

  データの重要度　←→　コスト

それほど大切でないデータに過剰なセキュリティーを求めると、手順や費用がかさみ、かえってコスト高になるということです。

ただ、アタッシェケースはコストが低い割に（フリーソフトで使いやすい）、セキュリティー強度もそこそこあるので、コストパフォーマンスはけっこういいかもしれません（手前みそ）。なので、あなたのちょっとした秘密や、少々やばめのファイルなどを守るために使ってみる価値は十分あると思います。

おそらくそんなことをする方はいないと思いますが、第三者へ漏れてはまずい企業機密や、国家的な重要事項をこの「アタッシェケース」で運用するというのはおカドちがいです（^^;）。

フリーソフトに、あなたのプロジェクトの命運を預けるには荷が重すぎます。会社が設定するしかるべきセキュリティー規則で運用してください。こういったデータを守るには、もう少しコストをかけるべきです（当たり前）。


アタッシュケースではない・・・

まったくどうでもいいことなんですが、最近まで作者はあのカバンのことを、「アタッシュケース」と呼んでいました（^^;　作者以外にも、けっこう勘違いしている方は多いのではないでしょうか？

たしかに辞書には載っていませんし、このソフトを開発するにあたり、ネーミングをつける段階で初めて知りました。「アタッシェ」が正しい。

そもそも「アタッシェ」とはフランス語のようでして、岩波書店の広辞苑によれば、

  －－大使館・公使館に派遣される専門職員。古くは特に、大使館・公使館付の武官。

だ、そうです。

つまり外交官などが持つ書類カバンのことを指して「アタッシェケース」となったようですね。

ちなみにインターネットで検索すると、「アタッシュケース」と誤記したアタッシェケース販売サイトがいくつか見つかりました（笑）。

最近、ユーザーの方から、「某ドリンク剤のCMの曲で“♪アタッシュケースは勇気の印～”などという歌詞があって、それで勘違いしてました」というメールをもらいました。そういえば作者もこれが原因で勘違いしていたのかもしれません（^^;）。


開発しようと思ったワケ

大切な仕事のデータを自宅へ持ち帰る際に、そのままポータブルHDDなりCFなり、生データを入れて持ち歩くのは、ちょっと怖いなあと思ったのがきっかけです。企業機密とは言わないまでも、落として誰かに拾われてしまったときにイヤだなあと思いまして。

つまるところ「データを持ち歩く際に暗号化する」という目的からスタートしていますので、自分のＰＣ上でデータを隠蔽するというところには比重が置かれていません。そもそもパスワードを記憶できるオプションがあること自体、セキュリティー的に問題アリです（^^;

よくユーザーさんから「常駐監視してファイルが閉じられたら、自動で暗号化するような機能をつけてください」と求められるのですが、それは僕の望む方向ではないのです。厳密にセキュリティを保ちながらやるのは、かなり難しいということもあるのですが・・・。やるとしたら、アタッシェケースではなく、別アプリで作ることになるでしょうか。

アタッシェケースを手がける前にも、市販のものも含め「暗号化ソフト」と呼ばれるものは様々試しましたが、いまいち使い勝手がよくありませんでした。しばしば暗号強度が高いといった売り文句を見ますが、BlowfishやRijndaelほどの強度もあれば、素人ならほぼ解読不能です。

高い暗号強度のアルゴリズムを採用しても、パスワードを総当たりで入力され破られる可能性の方が高いような気がします。ましてや、あなたがクラッカー攻撃の危険にさらされている人だったら、もっと他にあるセキュリティの高い方法を選択するでしょうし（笑）。

そこで最後に辿り着くのは、日常的な使い勝手の善し悪しじゃないかなあと思うのです。
フォルダごと暗号化できなかったり、ファイルのドラッグ＆ドロップがない、関連付けに対応していない、細かいところでは、パスワード入力したあとEnterキーで暗号化開始できなかったり（^^;　日常的に使うなら、もう少し細かい使い勝手を工夫してもらえたらいいのに・・・

けっきょくそうした使い勝手のいい暗号化ソフトがないので、自分で作ってみることにしました。

フリーソフトである理由

これもよくメールで聞かれるのですが、たいした理由はありません。
「シェアウェアにするとサポートなどに時間がとられ面倒だから」というのが一番の理由でしょうか（^^;）。金銭を挟むと、多少なりとも責任が重くなるでしょうし。

そもそもは自分が使うために開発したのですが、それを自分だけの使用で終わらせてしまうのはもったいないなあといった理由もあります。せっかく作ったのだから、他の人にも使っていただきたい。

また、ユーザーさんからのバグ報告や要望などで、アタッシェケースが少しずつリファインされていくのも小さな喜びだったりもします。ようは自己満足ですね（笑）。

そんなこんなでアタッシェケースを作ってフリーで公開しています。
皆さんの秘密を守るのに、少しでもお役に立てたらと思います。


今後の予定

現在のところ、バグ（プログラム上の不具合）修正を優先的に行っています。
他に寄せられている要望として、以下のようなものがあります。

  • 復号化したファイルを監視し、ファイル編集後に自動的に再暗号化する機能
    あまりにも要望が多いため、検討中。ただ、別アプリになるかも・・・。

  • RSA暗号を研究中
    ver.3では公開暗号鍵も扱えるようにしたいなあと研究中です。やっぱり相手に鍵を渡せないときにあると便利ですよねえ・・・。

    などなど・・・

あくまで上記にあることは「予定」ですので、最終的には機能として盛り込まない可能性もあります。あしからず。

あとは、ユーザーさんの反応を見ながら、実現が簡単で、かつアタッシェケースのコンセプトからズレない程度の機能を優先して検討していこうかと思っています。もし何かあればお気軽にメールください。（→連絡先（サポート））

ただ、全部の要望を受け入れるとは限りませんので、「こうなったらいいのになあ」程度の要望にとどめてくださいね（^^;


Blowfishについて

 暗号化アルゴリズム Blowfishとは、Bruce Schneier氏が作成し、著作権フリーで一般に公開している "Blowfish"と呼ばれているものです。可変長448bitキー64bitブロックの暗号化アルゴリズムで、扱いやすいわりに処理が高速で、暗号強度も高いのが特徴となっています。 なお、実装には、C++用に公開されている Jim Conger氏のクラスを利用しています。本ソフトとのアタッチメント部分を少し改良しただけで、ソースのほとんどをそのまま使用させていただいております。 暗号化アルゴリズムに興味のある方は、以下にある作者のサイトへアクセスしてみてください。前述のソースなどを誰でもが入手し、使用することができます。こういったものを利用して、使い勝手の良いセキュリティーソフトが、世の中にもっと出てくることを期待しています（フリーだとなおうれしい（^^;）。 　Schneier.com（英文） 　http://www.schneier.com/index.html 　Schneier.com: Blowfish（英文） 　http://www.schneier.com/blowfish.html


圧縮アルゴリズムについて

圧縮処理については、zlib ライブラリ（ver.1.2.3）を組み込んで使っています。基本的にソースの中身は改変せず、そのままの形で使用しています。

zlib とは、 zip や gzip に使われている圧縮アルゴリズムをライブラリ化したもので、フリーソフトウェアとして公開されているものです。圧縮率が高く（lzhよりも高いと言われていますがデータの中身に依存します）、処理も高速です。何よりもアーカイバDLLを必要とせずに、圧縮機能を独自に用意できるメリットが大きいです。

作者は、Jean-loup Gailly氏と、Mark Adler氏です。

使い勝手のいいフリーライブラリを用意していただいたことに感謝いたします（といってもこれを本人が見てくれるとは思えませんが（^^;））。

なお、zlibについての情報は、本家本元である以下のサイトを参照ください。
最新のソースはもちろんのこと、サンプルなどがアップされています。

  zlib Home Site（英文）
  http://www.zlib.net/

ちなみに、最近広く使われているグラフィックデータフォーマット「PNG」でも zlib 圧縮が使われているようです。そうした情報も上記のサイトで、あわせて参照することができます。