システム ポリシーとシステム ポリシー エディタ

システム ポリシー エディタ (poledit.exe) は Windows NT 4.0 スタイルのユーティリティであり、Windows NT 4.0 クライアント用のシステム ポリシーと、Windows NT 4.0 スタイルの Windows 2000 クライアント用のシステム ポリシーの設定に使用します。Windows 2000 クライアントの場合は、システム ポリシーの代わりにグループ ポリシー を使用してください。

次の表は、Windows オペレーティング システムの各バージョン間の、システム ポリシー ファイルの互換性をまとめたものです。

.pol ファイル作成時の OS | 実行時の OS
Windows 2000 | Windows 2000、Windows NT 4.0
Windows NT 4.0 | Windows 2000、Windows NT 4.0
Windows 98 | Windows 98、Windows 95
Windows 95 | Windows 98、Windows 95

操作方法

Windows 2000 クライアントの場合は、「グループ ポリシー」を参照してください。


目的

    操作方法

  • ドメインに対して新しいポリシーを作成する
  • 各コンピュータのポリシーを設定する
  • グループの優先順位を設定する
  • ポリシー テンプレートを追加する
  • ポリシー テンプレートを削除する
  • ネットワーク コンピュータのレジストリを変更する


ドメインに対して新しいポリシーを作成する

ドメインに対して新しいポリシーを作成するには

  1. システム ポリシー エディタを開きます。
  2. [ファイル] メニューの [新規作成] をクリックします。
  3. レジストリ設定の変更内容を適用する対象を指定するには、次のようにします。

    4. ドメイン上のすべてのユーザーについて HKEY_CURRENT_USER レジストリの設定を変更するには、[既定のユーザー] をダブルクリックします。

    ドメイン上のすべてのコンピュータについて HKEY_LOCAL_MACHINE レジストリの設定を変更するには、[既定のコンピュータ] をダブルクリックします。

  4. レジストリの設定に追加するには、次のような [編集] メニューのオプションをクリックします。

    5. 特定のユーザーについて HKEY_CURRENT_USER を変更するには、[ユーザーの追加] をクリックします。

    特定のコンピュータについて HKEY_LOCAL_MACHINE を変更するには、[コンピュータの追加] をクリックします。

    特定のグループについて HKEY_CURRENT_USER を変更するには、[グループの追加] をクリックします。

  5. 必要に応じて、追加したその他のポリシー ファイルのポリシー設定を構成し、[ファイル] メニューの [名前を付けて保存] をクリックします。
  6. [保存する場所] ボックスで、プライマリ ドメイン コントローラ (PDC) 上の Netlogon フォルダを指定します。たとえば、次のように指定します。

    7. ¥¥PDCServerName¥netlogon

  7. [ファイル名] ボックスに、「NTconfig.pol」(Windows 98 と Windows 95 クライアントでは、「Config.pol」) と入力し、[保存] をクリックします。

警告

  • レジストリを正しく編集しないと、システムが正常に動作しなくなる場合があります。レジストリを変更する前に、コンピュータ上の重要なデータのバックアップを作成する必要があります。

注

  • システム ポリシー エディタを開くには、[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「poledit.exe」と入力します。
  • システム ポリシー エディタで、本のアイコンをダブルクリックして、利用可能な設定を表示します。ポリシー設定のチェック ボックスがオンになっている場合は、そのポリシーが適用されます。
  • ポリシーは、Windows NT 4.0、Windows 98、または Windows 95 を実行する各コンピュータ上で、ユーザーがログオンすると適用されます。
  • システム ポリシーの詳細については、「移行の問題」 を参照してください。


各コンピュータのポリシーを設定する

各コンピュータのポリシーを設定するには

  1. システム ポリシー エディタを開きます。
  2. 各コンピュータで、[ファイル] メニューの [レジストリを開く] をクリックし、[ローカル コンピュータ] をダブル クリックします。
  3. [ネットワーク] の横のプラス記号 (+) をクリックします。
  4. [更新] の横のプラス記号をクリックし、[リモート更新] をクリックします。
  5. レジストリ プロセスのエラー メッセージをクライアント コンピュータに表示するには、[エラー メッセージを表示する] をクリックします。
  6. ドメイン コントローラ以外のサーバーからポリシー ファイルをダウンロードするには、[更新モード] の [手動 (パスを指定する) ] をクリックし、パスを指定します。
  7. 必要に応じて、コンピュータ上のほかのポリシー ファイルのポリシー設定の構成を完了し、ポリシー ファイルを適切なフォルダに保存します。

警告

  • レジストリを正しく編集しないと、システムが正常に動作しなくなる場合があります。レジストリを変更する前に、コンピュータ上の重要なデータのバックアップを作成する必要があります。

注

  • システム ポリシー エディタを開くには、[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「poledit.exe」と入力します。
  • ポリシー ファイルの拡張子が .pol であることを確認してください。
  • レジストリにアクセスできるのは、そのコンピュータに対して管理者アクセス許可を持っている場合だけです。


グループの優先順位を設定する

グループの優先順位を設定するには

  1. システム ポリシー エディタを開きます。
  2. [ファイル] メニューの [新規作成] または [ポリシーを開く] をクリックします。新しいポリシーを作成した場合は、グループの優先順位を設定する前に、ポリシーにグループを追加する必要があります。
  3. [オプション] メニューの [グループの優先順位] をクリックします。
  4. [グループの順位] で、グループをクリックし、[上へ移動] または [下へ移動] をクリックします。

注

  • システム ポリシー エディタを開くには、[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「poledit.exe」と入力します。
  • 現在のポリシーのグループが表示されている場合は、[グループの優先順位] メニューは使用できません。
  • 一覧の一番上に表示されているグループが、最も優先順位が高くなります。
  • グループの評価順が重要になるのは、一部のユーザーが複数のグループに所属し、それぞれのグループに対してポリシーが定義されており、同じポリシーの設定値がグループ間で異なる場合です。


ポリシー テンプレートを追加する

ポリシー テンプレートを追加するには

  1. すべてのポリシー ファイルを閉じます。
  2. .inf ファイルを格納しているフォルダ、通常は C:¥winnt¥inf に .adm ファイルをコピーします。
  3. システム ポリシー エディタを開きます。
  4. システム ポリシー エディタで、[オプション] メニューの [ポリシー テンプレート] をクリックし、[追加] をクリックします。
  5. ポリシー テンプレート (.adm) ファイルの名前を指定し、[開く] をクリックします。

注

  • システム ポリシー エディタを開くには、[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「poledit.exe」と入力します。
  • ソフトウェア ベンダーはポリシー テンプレートを開発して、自社プログラム用のポリシーを実装することができます。新しいポリシー テンプレートの作成方法の詳細については、『Microsoft Win32 ソフトウェア開発者用キット (SDK)』を参照してください。


ポリシー テンプレートを削除する

ポリシー テンプレートを削除するには

  1. すべてのポリシー ファイルを閉じます。
  2. システム ポリシー エディタを開きます。
  3. [オプション] メニューの [ポリシー テンプレート] をクリックします。
  4. 削除するポリシー テンプレートをクリックし、[削除] をクリックします。

注

  • システム ポリシー エディタを開くには、[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「poledit.exe」と入力します。


ネットワーク コンピュータのレジストリを変更する

ネットワーク コンピュータのレジストリを変更するには

  1. システム ポリシー エディタを開きます。
  2. [ファイル] メニューの [接続] をクリックします。
  3. ネットワーク上のコンピュータ名を入力します。
  4. [リモート コンピュータのユーザー] ダイアログ ボックスで、対話ログオンするユーザーをクリックし、[OK] をクリックします。通常、1 人のユーザーだけがログオンできます。
  5. [ローカル ユーザー] をダブルクリックし、必要に応じて HKEY_CURRENT_USER レジストリの設定を変更します。
  6. [ローカル コンピュータ] をダブルクリックし、必要に応じて HKEY_LOCAL_MACHINE レジストリの設定を変更します。
  7. [ファイル] メニューの [上書き保存] をクリックし、次に [ネットワークの切断] をクリックします。

警告

  • レジストリを正しく編集しないと、システムが正常に動作しなくなる場合があります。レジストリを変更する前に、コンピュータ上の重要なデータのバックアップを作成する必要があります。

注

  • システム ポリシー エディタを開くには、[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「poledit.exe」と入力します。
  • レジストリにアクセスできるのは、そのコンピュータに対して管理者アクセス許可を持っている場合だけです。